X-Surf

Our ethernet cards for Amiga computers

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
    1. Xsurf-100 and GVP scsi series II 8MB 4

      • madk71
    2. Replies
      4
      Views
      617
      4
    3. madk71

    1. XSurf-100 and GRex4000D 5

      • steenlund
    2. Replies
      5
      Views
      211
      5
    3. Jens

    1. X-Surf-500 on other accelerators 2

      • madk71
    2. Replies
      2
      Views
      903
      2
    3. madk71

    1. X-Surf-500 Issues 2

      • mnice
    2. Replies
      2
      Views
      79
      2
    3. mnice

    1. X-Surf-100 problem, not working 1

      • quad
      • quad
    2. Replies
      1
      Views
      71
      1
    3. Jens

    1. X-Surf-100 and TF534 2

      • madk71
    2. Replies
      2
      Views
      348
      2
    3. Jens

    1. X-Surf broken ISA card 2

      • Kawazu
      • Kawazu
    2. Replies
      2
      Views
      631
      2
    3. Storm

    1. X-Surf 500 green vs red led 1

      • KKR75
    2. Replies
      1
      Views
      122
      1
    3. Jens

    1. X-surf 500 and WHDload 3

      • madk71
    2. Replies
      3
      Views
      460
      3
    3. madk71

    1. X-Surf 100 problems 2

      • karlramm
    2. Replies
      2
      Views
      621
      2
    3. karlramm

    1. X-Surf 100 not showing in boot menu 4

      • gdonner
    2. Replies
      4
      Views
      553
      4
    3. BobEller

    1. X-SURF 100 and ZZ9000 7

      • FranciscoJr
    2. Replies
      7
      Views
      227
      7
    3. FranciscoJr

    1. X Surf 500 communication issue 8

      • digitalman
    2. Replies
      8
      Views
      777
      8
    3. digitalman

    1. Surfing with X-Surf500 4

      • madk71
    2. Replies
      4
      Views
      663
      4
    3. captain_zzap

    1. Question about X-surf-100 with Mediator PCI 4000DI 3V MKIII Busboard 5

      • FranciscoJr
    2. Replies
      5
      Views
      316
      5
    3. FranciscoJr

    1. problems with x-surf-100 on A4000D with 060 accelerator 5

      • frossmant
    2. Replies
      5
      Views
      577
      5
    3. Jens

    1. Original Xsurf 1

      • Milesunder
      • Milesunder
    2. Replies
      1
      Views
      538
      1
    3. Jens

    1. Issues with XSurf500 12

      • digitalman
    2. Replies
      12
      Views
      472
      12
    3. Jens

    1. Download expired through Order History 4

      • KKR75
    2. Replies
      4
      Views
      205
      4
    3. KKR75

    1. Amiga O.S. 3.1.4 with X-Surf500 3

      • ebogerd
    2. Replies
      3
      Views
      801
      3
    3. madk71

Display Options