MK3 no output

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Jens-as recommended, here is a new thread.


    Received MK3 and tried installing this week in an NTSC A1200 rev 1D system with 3.1.4 ROMs. Only expansion is a Kipper SDE+ RAM board (which has been removed for isolation).


    I have tested both VGA and HDMI outputs with different cables. I've run the VGA output to an OSSC, which does not detect any signal activity. Lisa has been scrubbed with scratch brush and wiped with IPA. Multiple re-seats of both CIA and LISA boards (appears to be latching well).


    If there are test points for troubleshooting with a VM, that would help.


    Cheers for the support.

  • I don't spot any ripped-off component. Please try to re-flash the unit - you should run the latest update anyway. Does the config tool find the unit?

  • I've tested it with several re-seats but the config tool reports no hardware. No luck so far.


    BTW- great appearance at AmiWest 2020 yesterday, Jens. Exciting to see your commitment to the Amiga future and the announcement of new Picasso96 drivers.

  • Sorry Jens. I'm out of pocket for a few weeks and won't be able to follow up until around 15 NOV.


    I've stripped the A1200 down to the bone and running the machine off a Meanwell conversion PSU.

  • That's of course the worst thing you can do. Please read our power supply FAQ and fix that - you're putting the system in danger.

    LOL, danger must be my middle name as my A1200 (rev 2.B) with a Blizzard 1260 and SCSI is using a Meanbad chassis powersupply (4A on the 5V rail) that I put together as my old Commodore brick that started to smell like a fish market. It worked with a mechanical hard drive before I changed to a CF card setup. I was a bit worried when I got the Indivision AGA MK3, but it ran for over a day straight with no problems, and still does so. I guess mileage can vary for people.

  • I guess mileage can vary for people.

    With MeanWell changing the specs (especially on ripple) frequently, and other factors like length of the cable, using shield or not - yes, that makes a huge difference.


    I never said that MeanWell PSUs are bad - they are just not suitable as external power supplies for the Amiga.

  • I never said that MeanWell PSUs are bad - they are just not suitable as external power supplies for the Amiga.

    I know Jens, we just call them Meanbad at work (different models for building automation) as a joke, as we have had a few old ones crap out.

    I have noticed that Meanwell have changed the specs on a few data sheets I looked at for the RT-50B. I'm assuming mine is the 'newer' version.

  • I'm assuming mine is the 'newer' version.

    ...with higher ripple, hence even more likely to crash the computer? I guess the linear regulator for CPU core voltage helps. And what probably helps even more that you appear to work in a similar area, so you know about voltage drop on a long cable. My guess is that anyone in the right mind would make the cable between source and sink as short and as thick as possible. This is all legit if you know what you're doing - you probably get frequent reviews of shielding and grounding if the automation stuff you do for a living is following some kind of quality control. One of my industrial designs is a high-reliability communication module used in areas where human life depends on them, so I'm well aware of multi-level safety and redundancy checks.


    On the other end of the spectrum, there's commercial offerings using a MeanWell chassis with a 1.5m long AWG18 cable that work barely on an unexpanded Amiga, but fail as soon as you expand the machine. And of course, people deduct that the device that was installed last is at fault. They end up in our support forum (because no other vendor in the market has one), and discover that the shiny-new PSU they bought was just false advertising. Sigh.

  • I fully expected that if I did have a problem that the culprit would have been the power supply (due to not meeting Commodore specifications) and NOT the Indivision AGA MK3. I am surprised, probably as much as you, that I actually have a very stable A1200 that is used a lot, with the current setup.

    I know all to well about voltage drop at work and we often have to do the calculations and install the next cable size up to overcome the problem.

    All communications cabling is sheilded from induced emf and noise.

  • Back from a great vacation & returning to this problem.


    Tested with a variety (OEM) of PSUs and feeling pretty confident that is not the problem.


    Buzzed all available solder points on Alice and matched to Amiga PCB Explorer on the top of the board with confidence that socket interface is good.

    Verified LDO @ L4 5.04vdc in and 3.3vdc out

    Verified XC95 is getting 3.3vdc

    Verified DRAM is getting 3.3vdc


    Zero signal on either VGA or HDMI end. Ran through OSSC for sanity.

    I have not done further investigation beyond this.

  • I fear that if we're getting this one back for testing, we see a "works out of the box" again - there have already been two cases like this, and both customers did not want to continue trying, especially because they were both in Britain, where sending the machine would have been prohibitively expensive. This one is in the US, right?

  • I did see a probably-bad pin on the 4th picture yesterday (top left, left row in your picture), but that only carries one of the colour bits and should not cause the picture to fail completely.


    What you could try is to make the rescue disk (launch the config tool without hardware being found, then choose the menu item from the drop-down menu), then run that rescue disk, in case the flash lost it's contents when you tried with the bad power supply.

  • Unfortunately, I've run out of PSUs to try and survive a cold boot without having to use the rescue disk. 3 OEM ones and 2 Meanwell conversions. All support my A500 with accelerator and other hardware just fine (which I am aware is anecdotal).


    Appreciate the attention. Anything else come to mind?