Indivision AGA Mk 3 bad picture

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hello. I just received my Indivision AGA Mk 3. The problem is there is no proper picture, just big grey and white fields and artifacts. :(

    - The output from HDMI and VGA is the same.

    - From the RGB output of the Amiga the picture is normal, resolution is PAL HiRes.

    - The Indivision on-screen menu displays normally over the garbage image.


    I have tried to double check the sockets are seated properly, they seems to be.

  • Please try cleaning the Lisa chip with alcohol and an old toothbrush. If that does not help, please describe your complete setup with all expansions and the power supply you are using.

  • I have scrubbed the pins with a q-tip and contact cleaner. It did not make any difference, unfortunately. It is an A1200 rev 1.D4, with an 80 W Pico PSU, CF-IDE adapter and an Apollo 1260. Disconnecting the 1260 did not make any difference.

  • Q-tip might not be the best idea, as that may leave residuals. I really mean a toothbrush, as that will really "do work" on the pins.


    Does the config tool find the hardware when installed? Is the PicoPSU really internal, bypassing the input filter?


    Can you take a picture of the output and post it here? Maybe the type of artefact helps identifying the source.

  • The Pico PSU does not bypass the input filtering on the mainboard, BTW. It feeds into the solder points where the original power connector would have been.

  • The Pico PSU does not bypass the input filtering on the mainboard, BTW. It feeds into the solder points where the original power connector would have been.

    That means that the PicoPSU regulates to 5V, then you have a cable drop, and then another drop in the input filter. Voltage may very well be a problem here, as the PicoPSU does not know about the drop on the way to the current sink.


    Do you have a space A1200, or a friend where you can try the unit? It did pass QC here, so I assume it's something simple.

  • I measured 5.01 V at the PSU, and 4.96 V at the Lisa VCC pin. I also had a look at the Indivision under the microscope but did not find anything immediately suspicious except a bit of missing solder mask in a few places.


    I will test the Indivision on another A1200 today.

  • Hi, not sure if this could help, but I have a similar setup: internal 90W picoPSU, soldered, not bypassing the filter (sorry for OT, but which way is better?). My MKIII is correctly detected and working. Ask for any cross-check.


    /D

  • Thanks for the input, Sneezeface!


    For the record, I have now tested it in my friend's A1200 (in which he normally uses an Indivision Mk2cr which works perfectly).

    The result was exactly the same. Same picture, same artifacts. So it would appear something is wrong with the card itself.

  • Reffy, what's the order ID or the warranty ID you got? Just trying to find out where on the planet you are. If you're in Europe, then sending the unit back is not too expensive, and we can take a look at it here.

  • ..so a return shipment would go via a customs border. Can you take high-resolution pictures of both sides of the board? I have located the QC pictures and can't find anything suspicious on them. If your camera has a "macro" setting (usually depicted with a flower), please use that. Direct sunlight helps a lot with such photos. If you can't upload the pics here, just send them directly to my eMail address.

  • Hi, Jens. Installed the Indivision again today and tried to flex it about and apply some pressure on the socket, chips etc. That made no difference.


    I then probed the socket solder points with my oscilloscope to see if all the pins actually made contact, which they did. Then I started probing around to see if voltage was getting around the board, which it seemed to (of course, I could only probe on the top side). Then I probed the pins on the various chips to look for signs of activity (of course, I have no Idea what the signals are supposed to look like), and discovered that while the Xilinx and the Etrontech chips showed signals that indicated activity, the little unmarked P49AF chip just above C89 seemed to show nothing at all - it does get +3.3V on pins 13 and 14, but all the other pins seem dead.


    Of course, I have no idea if it's supposed to be that way.

  • Ah, forget about it. I put it under the microscope and realized that chip is for the CIA input. I didn't connect the CIA adapter this time, so that's why there were no signals. So that's not going to be much help.