X-Surf

Our ethernet cards for Amiga computers

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
    1. Surfing with X-Surf500 1

      • madk71
    2. Replies
      1
      Views
      16
      1
    3. captain_zzap

    1. Amiga O.S. 3.1.4 with X-Surf500 3

      • ebogerd
    2. Replies
      3
      Views
      255
      3
    3. madk71

    1. X-surf 500 and WHDload 3

      • madk71
    2. Replies
      3
      Views
      32
      3
    3. madk71

    1. problems with x-surf-100 on A4000D with 060 accelerator 5

      • frossmant
    2. Replies
      5
      Views
      70
      5
    3. Jens

    1. X-Surf 100 not showing in boot menu 4

      • gdonner
    2. Replies
      4
      Views
      91
      4
    3. BobEller

    1. Xsurf-100 and GVP scsi series II 8MB 4

      • madk71
    2. Replies
      4
      Views
      110
      4
    3. madk71

    1. X-Surf broken ISA card 2

      • Kawazu
      • Kawazu
    2. Replies
      2
      Views
      116
      2
    3. Storm

    1. ACA 500 PLUS X-SURF500 MODULO OROLOGIO 2

      • Giuseppe Mastroianni
    2. Replies
      2
      Views
      117
      2
    3. Jens

    1. X-Surf 100 problems 2

      • karlramm
    2. Replies
      2
      Views
      182
      2
    3. karlramm

    1. Original Xsurf 1

      • Milesunder
      • Milesunder
    2. Replies
      1
      Views
      239
      1
    3. Jens

    1. X-Surf-500 on other accelerators 2

      • madk71
    2. Replies
      2
      Views
      403
      2
    3. madk71

Display Options