ACA1221 and 3.1.4 ROM

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
  • Hi, I have an ACA1221 (not EC) board, and on Kickstart 46.65535 I can't seem be able to use it: the ACATUNE command fails saying "Version exec.library is 40+". The fast ram is not automatically detected (I use 3.1 OS) and without ACATUNE I'm lost... how can I solve this? Thanks


    EDIT: I checked, my A1200 actually has the 3.0 Roms, but Workbench says "Kickstart 46.65535". I've probably messed things up formatting the internal CF with OS 3.1.4 (that should not even work on 3.0) and then switching to OS 3.1. Still, I wonder about the error message...

  • ACATune checks for the version because it knows that V39 does not add the memory - in that case, it will add all available mem. V40 does automatic adding of memory starting at $0800.0000, so if that's found, ACAtune will not add the mem to the freemem list, because it would be in the list twice, resulting in crashes.


    I don't know if this automatic adding of memory is in Kick3.1.4, but if you have that, you can use MapRom from file to try.

  • Thanks for the info. I managed to get in a situation when RAM wasn't automatically added and ACATune would not work (formatted the internal CF with OS 3.1.4, then used OS 3.1, with an A1200 that mounts the 3.0 KickStart). Will probably reformat all and switch to 3.1 Kickstart soon.