Micromys

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
  • Hi,


    My Micromys V4 doesnt work anymore.

    Ive only used it a couple of times but that was some years ago.

    It hasnt been exposed for anything, just laying in a box.

    Is there anything I can do about it or do I have to buy a new one?...

    Greatful for help, regards...


    /Mikael

  • These normally don't break "just like that" - the only thing I can imagine is that it is mechanically demaged - either a bad cable, or the 16MHz crystal, which is sensitive to shock.


    What computer are you trying it on? Micromys V4 has auto-detection which may fail on a certain machine or if you're attempting hot-plug.

  • Hi,

    Its on a A1200 and a CD32.


    There is no direct visible damage on it.

    I Shall measure the cables.

    Is it possible for me to exchange the crystal?


    Ive just recapped my old CD32 and installed a used TerribleFire board!....

    Always thought you would release such a board first!...


    I have quiet a few of youre other Amiga products and thet are all awesome!.. 🤗🤗


    regards...


    /Mikael


  • The crystal of Micromys V4 is a standard HC49-SMD 16MHz crystal with 20pf load capacitance. Can't get any more "standard" than that. However, unsoldering this may be a challenge, as most of the contact area is under the plastic protector, and you will have a hard time heating the whole area of both pins at the same time. You should maybe measure with an oscilloscope if it swings at 16MHz - if it does, there is no need to solder on it.

  • Hi again,


    All of the cables are fine and the crystal swings so in this case it seems like some other component has thrown in the towel!.....

    I think I'll have to order a new one then...


    Thanks for the response!..


    best regards,...


    /Mikael