BigRam+ 256MB not working in A4000D

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi, just received my BigRam+ 256mb, but the system crashes as soon as it tries to access the memory.

    Everything boots up fine, and show 290MB ram (256 + 16 + 8).

    When i start to copy a 50 mb file to ram, the system crashes when it starts to use the 256 mb ram. (Guru 800004)

    Have tried to all zorro slots with same result.


    The system is A4000D OS 3.1.4 040 25mhz (A3640). Buster-9

    Original Amiga daughterboard.

    Everything is recapped.


    Have also

    GVP SCSI HC+8 II with 8 mb ram and AD516 sampler card which is working flawlessy with this daughterboard.


    Have removed all cards and tried with only the BigRam card inserted.



    If i try to speedtest the memory area for the 256mb ram, it crashes also.


    Any suggestions?

  • Ths one passed QC in 2019, then was re-checked according to new QC directions on January 21st, 2021, then not touched until it was shipped to you on Feb 19th. With two QCs passed, I'd rate it extra-unlikely that there's a problem with the hardware. I'd instead look for a contact problem (please remove card, clean the contacts with IPA and a micro fibre cloth), and make sure that the bus is not overclocked. Some people like to overclock the 3640, which also results in a higher clock for the whole system, including the Zorro bus. BigRamPlus is not made for that, so please go back to original clocking if you are among those persons.

  • Ok so far no luck.


    My A4000 is not overclocked (25mhz).

    - Cleaned everything with alchohol

    - Tested with kickstart 3.0 and 3.1, booted from workbench disk.


    - Tested the computer with all kind of tests with DiagRom 1.2.1 (all motherboard RAM ok)

    The Bigram card is also found correctly by DiagRom, but DiagRom could not be used to test the zorro ram.


    - Tested all ram with Amiga Test Kit 1.16, and there i could test the BigRam and my zorro ii ram, and no faults were found. It ran for at least 24 hours.




    As soon as i try to copy data in the workbench or speedtest the ram, it crashes.

    A little wierd that the test kit managed to test the BigRam without any issues.


    I can't find any fault with my computer, and i haven't had any issues with it so i guess i must try to test this card in antoher A4000 to see if the trouble is recreated there.


    Could a new crystal oscillator do any difference?

  • The oscillator is indeed a mechanical part, sensitive to shock, but it normally either fails completely, or just keeps working. The new (blue) BigRamPlus uses an SMD oscillator, a 3.3V part, so it's even "shielded" from power supply noise. These SMD oscillators are rock-solid - if the board works in a test, you might even be looking for a software error, maybe a stack overflow or something similar.

  • I have tested the card on another stock Amiga 4000/030 (Perfect condition), and the result was the same as on my machine.


    Amiga test kit tested the ram ok, but as when i boot into workbench and tried to copy files (entire Workbench disk) into ram, the machine crashes when the BigRam memory is used. Sometimes recoverable alert, sometimes instant reboot.

    Sometimes though, it was able to copy some data into ram before it crashed. For instance after 10 mb of usage.

    Tested it many times on this machine and it crashed every time.

    So my assumption is that there is something wrong with this BigRam card.

  • Card arrived, and it's passing all tests we throw at it. Changed the computer as well (A3000/030/25 and A4000/ec030/25), but could not reproduce a crash by filling up RAM disk.


    Please report back what version of the copy command you have installed, and precisely describe how you've copied stuff to the ram disk.

  • The installation is OS 3.1.4 (with 3.1.4 roms) with update 3.1.4.1 installed. On top of that BestWB 1.3. MMU.library 46.20, 68040.library 46.3.

    Copy v45.4

    My HD is a 2.5 320GB Sata disk which is connecteed through an SATA to IDE adapter.

    Filesystem if PFS3aio 19.2

    Buster-9



    I have ripped some music to CDDA to disk and i start copying these files to ram. Each file is about 45 mb.

    I have also tried to just drag the workbench disk onto the ram disk.


    Could there be some issue with Zorro III only? I'm waiting for my zz9000 card, so then i can verify my Zorro III (Should show up in may).

    All of my Zorro II cards works perfect.

  • Ok, ZZ9000 finally arrived and i can confirm that i have the same issue with the ram with this card. So sadly :) there is something wrong with my hardware. The RTG is working ok, only the ZIII ram expansion is malfuntion, so exactly the same problem as with the BigRam.

    I noticed that my Buster is Rev-09, but the exact id is 390539-09 45-SUPER BUSTER. This is according to BigBookOfAmiga fitted in an A3000.

    Could there be a problem with this version? Is it tested with this version?


    Anyway, thanx for you help and please return the card to me (i'll pay for shipping of course) as it should be working perfectly.

  • Could there be a problem with this version?

    Only with DMA cards. To my knowledge, the ZZ9000 does not use DMA. Buster-09 is fine with non-DMA Z3 cards. We actually use an A3000 with that Buster for testing our Z3 cards (X-Surf-100 and BigRamPlus).


    I am trying to wrap my head around possible reasons why it fails on a speed test, but doesn't fail on normal RAM test routines. Maybe it's just a simple contact problem of Buster in it's socket? Is that chip in a socket on your computer?

  • I removed the Buster-09, soldered on a socket and inserted a Buster-11. Now everything is working perfectly. BigRamPlus is working and my zz9000 card i working. Haven't tried both of them together though since i've read that this is not possible.

    So the solution was to upgrade to Buster-11.


    I have tested this with my A3640 and A3630 card.


    As a curiosity, i can confirm that when using Buster-09 with my A3630, i managed to get BigRamPlus to work if i put it in the second top most socket on the daughterboard. Doing the same with my A3640 resulted in crash.

    I've read that some ZIII bursts stuff are disabled when using the 030 card, so this is maybe why it work. Wild guess :)


    Anyway, after upgrading to Buster-11, there are no more problems and i can use the card in any socket.