Indivision AGA Mk 3 bad picture

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • A return was shipped to Norway last week, but without a customer ID (the "K" number on the inoice), it will take me too long (at least for a Monday) to locate that shipment.

  • On my original invoice?

    I Can't find any invoices received by e-mail. I only have an order confirmation, a payment request, and a mail with the tracking number for the original shipment, and there is only and order number, no customer number.

    Was the invoice sent on paper only?

    At any rate, I would not expect to receive a package from Germany in just a week in these times.

  • Without revealing too much personal data in public, I can only say that the parcel to Nesoddtangen, Norway has already arrived in the destination country where it's prepared for customs. Since we take part in the VoEC scheme, there should be no charge for you - in case that is your parcel, of course. If you want to get the tracking number, please send me an e-mail; I don't want to post the number here in a publicly-accessible forum.

  • No worries. It arrived last night. Tested it today and it works perfectly.

    I would have liked an e-mail or something confirming you had looked at the faulty board and decided to send a replacement - just so I didn't wonder what was happening. I don't stress about the time stuff takes - especially not retro computing stuff. Small enthusiast companies or hobbyists just should not be treated like you would Microsoft or ASUS or whoever. Everyone who creates something for the Amiga should be treated like a heroes and given plenty of good will and leeway. I just don't like being left in the dark.

    Other than that - thanks for excellent service!

  • So... It worked OK for a few days and today when I switched the computer on there was no VGA signal. There is power to the board (4.96v) and the on board oscillator is working. There is no signal on HDMI, and the config tool does not detect the card.

    The computer still works perfectly, no problems via RGB.

  • Before we jump to conclusions and believe in a repeated defect - can you remove the unit, clean the Lisa chip and re-seat it?

    Also, please describe the whole setup, including all expansions and the exact way you've connected your PicoPSU (?). I know you've posted voltage readings before in this thread, but they are not really worth much unless we know the type of multimeter and it's precision, and of course the way the PSU is connected, other power-using devices in the computer. So before we send things back&forth again, it would be better go get the whole picture and find the cause (if it's not a bad contact on the Lisa chip).

  • I have yet again cleaned LISA, and the socket on the Indivision to no effect. I must point out that it worked well for a few days then, when I turned it on it was dead. I did not remove it or change anything in the meantime.

    As explained previously the Pico PSU is connected in place of the PSU connector on the motherboard. The PSU is connected with approximately 5 cm of thick copper cables from a modern PC PSU. I have measured with several multimetres and my oscilloscope and the PSU delivers 5,02 V across its 5 V and GND outputs, which drops to 4,94 measured on the Indivision.

    In the system there also is a CF-IDE adapter, and an Apollo 1260 50 mhz accelerator card that has not been overclocked. Removing it makes no difference.

  • I am getting a bit tired of this. You mailed me my board back saying it worked fine under testing, but I have now tried it on several A1200s and it's very dead indeed. I have also tried the Indivision Mk2 in this machine and it works perfectly.

    The Mk3 is not detected by the software and there is no picture.

    I have spent almost €300 on this now, I think that what I would like to do is return it. If you still find it working, you can sell it off to someone else. With some money back, I could buy an OSSC or Scanplus AGA instead.

    I have also sent mail about this a month ago, but not received a reply.

  • I'm happy to offer a refund, but I can't see any eMail that states anything like this. Do you have a message ID that I can look up? Or at least a time stamp where I can check?

    I do find it interesting that the unit worked for some time, then died. Maybe that PicoPSU modification is not such a good idea after all?

  • That was before I sent it back for testing. After it came back it's just dead all the time.

    I have had no other problems with the PicoPSU or any other PSU solutions. Please bear in mind - the Mk 2 has no problems on this system. Neither does any other peripheral. And the Pico is has smoother output than my genuine Commodore PSUs.

    But whatever the reason - on retro computers today, there will be all sorts of PSU solutions, and many people will use old, original PSUs that no longer conform exactly to spec. This is just a fact of life, and if new hardware isn't designed to account for this - well, that's just asking for trouble.

    Anyway, here is the mail heading (censored somewhat, as I'm not going to announce my e-mail address publicly):

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.