Broken RapidRoad - repairable?

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi, I recently bought a X-Surf 100 + RR second hand. The X-Surf works fine but the RR doesn't: I can put "rapidroadxs100usb.device" online in Trident but I get the error message "GET_DESCRIPTOR (len 8) failed: nak timeout (10)" followed by other error messages, and the usual entry of ISP 1520 doesn't show up under Devices. The white led does come on so I am assuming this means the CPLD is fine but the USB chip itself is faulty/has been fried.

    I have tested all this in a machine that has a different X-Surf 100 + RR in it (yes, I like them!) which works fine, so I know the basic set up is OK.

    I am trying the V1.7 drivers and I have tried with and without the Zorro jumper.

    So the RR is faulty (and in fairness it was sold as faulty). But is this repairable for less than the cost of just buying a new RR?

    Equally, I am open to suggestions for how to get this working! ^^


  • I am trying the V1.7 drivers and I have tried with and without the Zorro jumper.

    If the Z2 jumper doesn't make any difference, then installing Thor's MMU libraries (which is recommended with the new driver) will most likely not make a difference.

    We can't say from a distance what's wrong with the card - only a diagnosis here will tell us what needs to be exchanged. If the white LED comes on, it's not the typical latch-up that is caused by flakey power supplies. Just send the card, and we'll investigate it here. Please read this article before sending.