Docking Station and C64 keyboard

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi, I have a TC64 V2 and a V2 docking station. I have connected my TC64 to the docking station and connected a joystick and a C64 keyboard. The joystick works but the C64 keyboard doesnt. I have tried another C64 keyboard and it still doesnt work. The TC64 is running version beta 9h. Do i need to do anything else to enable the C64 keyboard? I have tried several different power supplies, the one i am using will deliver 1000ma.


    Thanks,

  • ok, I've fixed it. I updated the firmware to the latest release and its now working. I used flasher.exe to update, first time i ran this it said found Turbo Chameleon V1. very strange, the update finished but then the TC just showed a black screen with the LEDS lit. i ran flasher.exe again and it said found turbo chameleon V2, this time it updated and now works.

  • I have the same prob.

    If you want to get support solving this problem, please describe in detail what you've tried to solve it - did you have any trouble installing flash updates?


    Please note that this thread is marked "resolved" for a reason: It was a simple firmware-not-up-to-date problem.