604n not detected

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • I recently aquired an A600 revision 2D - Naturally I decided it needed some love ;-)

    I purchased an A604n ram expansion, but I am having problems getting it to be detected - it keeps insisting it only has 1mb ram :-(

    As all the units are tested before leaving Individual Computers, I am currently blaming the A600. Question is what could be the issue ?

    I did a recap of the board (much needed), and I cleaned the ram expansion connector with a pensil-eraser, but the problem persists (nothing but the 604n is connected to the A600).

    I'm open to any suggestions as to what to probe/test to debug this A600.

  • If the computer itself runs, I'd probe the memory with HRTmon, C-Mon or Megamon; it should be available at $0010.0000 to $001f.ffff. Fill the area with some test patterns first (all-00, then all-ff, then $55/$aa) and see if there's any errors.

    What version of the A604n is it? There's one with a bigger square logic chip and SD-Ram reaching under the Indivision socket, and another that only has a D-Ram memory chip and a tiny 14-pin logic chip (current version).

  • Thanks for the suggestion - I went ahead and tested a few memory locations using hrtmon.

    The memory is definetly there however it seems to not be working as expected - as far as I can tell bit 8 has an issue (lowest bit of highest byte in 16bit access). I.e. if I write #$7171 into an address and read it back then I get #$7071.

    This seems to happen for all the (even) addresses I tried between $10000 and $1ffff.

    When I get a moment then I'll sit down with the multimeter and check for continuity to pin 14 on the expansion slot.

    I figured that this would also be the reason that the memory was not detected, as it is my understanding that chip-ram detection is done via exec writing bytes to and from the ram to see what is there.

    However I went and checked the disassembly of the exec v1.2 that can be found online, and as I can tell they use the probe value #$F2D4B698 i.e. they specifically do not set bit 8. So maybe something else is also the issue regarding detection.

    The 604n is brand new, only removed from the packaging to insert for these tests - it's the version with the 14pin logic chip (604n rev2 ?)

  • The newer Kickstart of yopur A600 might use a different probe value (even multiple ones), as using a single proble value is no good for memory detection.

    Let's see what your multimeter probing reveals. While you're at it, you might also give the solder joints of the A604n RAM chip an extra visual inspection.

  • ok I finally got back to this.

    I have been probing pin 14 (DRD9) extensively and unfortunetly everything seems to be working as intended :-(

    There is connection from the expansion port to the onboard ram chips, the Agnus, and everywhere else I could see that it should be connected using the PCB explorer.

    Additionally I connected the A604n and tested for continuity between pin 46 on the indivision socket (also bit 9) and there was connection directly all the way to the agnus chip so thats good.

    Finally I did a visual inspection of the ram chip on the A604n and it looks to be perfectly soldered...

    Soooo.. I'm back to scratching my head on this one. I think my next move it to try and find someone else with an A600 where I can check the expansion to verify that the A604n is working as intended - just in case it's a faulty ram-chip on the A604n..

  • I have been probing pin 14 (DRD9)

    The failed test-value indicates DRD8 to be the culprit - counting starts at 0 on computers :-)

    So continuity check should go from Pin#13 to D-Ram pin#41 and Denise socket pin#47. You should also check continuity to one of the internal memory chips (don't have the pinout at hand).

  • right... counting starts at 0, trees grow downwards - and only 10 kinds of people in the world, those that understand binary and....

    I tested continuity between denise/indivision socket pin 47 to internal-ram chip pin 31 (DRD8) and all the way back to the agnus chip pin 6 - so thats also working as intended.

    D-ram 41 to denise socket 47 is also good so ram chip is soldered in properly.

    Since the A600 internal ram works fine and the data-path for DRD8 is intact I am more and more starting to suspect that that there is a bad bit on the ram-chip on the A604n. Really need to find another A600 to double check with.

  • I have been thinking about how to debug this further.

    hypothesis: The ram-chip on the A604n has a bad bit.

    This would mean that the A604n would be otherwise fully working (read: indivision slot and clock ports), only effect would be that the extended ram is not being detected since the poke/peek detection fails in the extended memory range.

    Then I should be able to plug in the Indivision ECS v2 that I also bought for this and it should be working fine - although only with the 1mb internal memory.

    If however the Indivision also fails or has graphical errors (i.e. the same corrupted bit) then the bit is somehow corrupted before reaching the A604n (read: on the A600 internally).

    So testing with indivision: if it has graphical errors (or fail toally) then A600 has a problem, if it works fine then it's almost certain that the A604n that has a bad ram-chip.

  • hypothesis: The ram-chip on the A604n has a bad bit.

    That would be a "first" in over a decade for me.

    So testing with indivision: if it has graphical errors (or fail toally) then A600 has a problem, if it works fine then it's almost certain that the A604n that has a bad ram-chip.

    Worth a try. However, if you get a chance to test the A604n in a different computer, or test a different mem expansion in your A600, that would be very informative. Further, trying a different power supply may also reveal a possible source of the problem.

    We do test every single unit for proper function, and I have a hard time remembering when the last A604n was here for service. These expansions "just work".

  • hypothesis: The ram-chip on the A604n has a bad bit.

    Alternative hypothesis: there's a short somewhere that's dragging down the signal in question?

    Does bit 8 always fail, or only when specific patterns are written? If you haven't already, try 0xffff, 0x0100 and 0xfeff.

  • Thank you for the feedback & suggestions.

    The A600 got kinda pushed to the side while I looked for someone nearby with an A600 to go test the A604n in. Unfortunetly I have been unable to find someone near - so in the end I folded and bought a "cheap" ram-expansion on ebay.

    The new "cheap" expansion worked fully, 2mb chip ram detected and available for use. Combined with the fact that all the probing/testing I could come up with for the motherboard all showed me that the it had no problem.

    I have to conclude that the A604n has a problem, if that is a bad-solder joint (hopefully), a bad bit in the ram-chip, or something else I do not know.

    At this point I feel the only option I have left is to send the A604n back for repair.

  • this just got more strange.

    I was starting to pack up the shipment, as part of the process I plugged the 604n in to verify that I had accurately described the issue... and lo and behold this time it worked...

    My first thought is that maybe it's oxidation on the expansion connector and that inserting/removing the "new" expansion somehow rubbed it clean - but since I tested continuity previously I can't see that being the situation. Maybe it just needed a few months on the healing bench ;-)

    In any case I have been running extensive ram-tests for a while now and everything works (so strange). Guess I'll just have to keep an eye on it going forward.

    Again thanks for the help/suggestions

  • We've had a few cases of A1200 computers not having chamfered edges on the CPU connector, causing contact problems. Please take a close look at your A600's trapdoor connector: Are the edges two 90-degree angles, or are they chamfered, so they look a bit like a knife's blade? This chamfering is meant to make insertion easier and to not bend contacts up when the connector is pushed all the way in. In the last years, at least two A1200 computers have surfaced that had no chamfering at all - maybe your A600 is one of the special ones without chamfering? Would be the first, but at this point, I wouldn't exclude it.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.

    • :)
    • :(
    • ;)
    • :P
    • ^^
    • :D
    • ;(
    • X(
    • :*
    • :|
    • 8o
    • =O
    • <X
    • ||
    • :/
    • :S
    • X/
    • 8)
    • ?(
    • :huh:
    • :rolleyes:
    • :love:
    • 8|
    • :cursing:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :whistling:
    • :evil:
    • :saint:
    • <3
    Marks thread as resolved after post creation.