My RapidRoad has ​​mysteriously stopped working.

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hello.

    I baught my RapidRoad last October (just over one year ago). It spent a few months in the box until I found time to install it. Once installed, it worked wonderfully until after a cold reboot. The white LED didn't come back on (I'm using a clear Amiga case, so I can see the light) and it stopped functioning. I turned my A1200 off for a bit and tried again, but the white LED does not come on any more. While checking the connections, I noticed that the RapidRoad board was quite hot, even thought my Amiga had been off for a few minutes. I have decided to remove it for now, but this is unfortunate, as I have become accustomed to using it. As I don't use my Amiga every day, I have probably only used the RapidRoad about a dozen times. I've read a lot about the power supply being related to this issue. I'm using my original DSP-A500 on my A1200. The A1200 was recapped long before installing the RapidRoad, so I doubt the new caps had anything to do with it. Also, I've only used it for transferring files via USB flash drives. Does anyone know what could have caused it to stop working and what needs to be done to remedy this issue?

    Thank you

  • I'm using my original DSP-A500 on my A1200.

    That model doesn't seem to be an original Commodore type. Can you post a picture?


    The A1200 was recapped

    Was the PSU also re-capped? The output capacitor on the 5V rail is the one that gets the highest ripple. Caps inside the A1200 only get high ripple when the output cap of the PSU has dried out.

  • The power supply is original and has not been recapped.

    You should re-cap it after more than 26 years :-)


    I'm not seeing any ripple on the +5VDC

    That straight line points to either the PSU not being loaded, or settings of the scope not chosen appropriately. We're talking about a switchmode PSU, so ther MUST be ripple - it can't be avoided, but only be reduced to a minimum.


    Anyway, the RapidRoad must be returned for the repair. I just recommend to re-cap the PSU before connecting the RapidRoad after the repair.

  • Yes, there was no load on the PSU at the time of that photo. I was planning to recap the PSU someday, but I'm now making it a priority. I won't attempt to reinstall the RapidRoad until after the recap is complete. Can you point me in the right direction to begin the return process?

    Thanks

  • Can you point me in the right direction to begin the return process?

    That would be the direction of your post office :-)


    We only have that one company address. Please include a short letter, so my staff knows what to do with the card. If the shipment crosses a customs border (which I assume it does, as your PSU is not 230V-capable), please make sure to declare it as "defective" with a remaining value of 5,- EUR - this will help it clearing customs without the need to drive to the customs office (that's almost three hours round-trip and can only be done in person or through an agent who is even more expensive).

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.