RR-Net MK3 exits to READY

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi! I am using RR-Net MK3 in cartridge mode (directly connected to C64). The C64 version is ASSY 250425. I believe this is a very common version.


    When I hold the C= key during power-up or reset, the message is "RR-Net MK3 CodeNet Server (R38)" and I can type a "CodeNet IP Address". The default is 192.168.0.64. Since my LAN router is using 192.168.1.1, and my computer is 192.168.1.3, I change the "0" to "1" so the RR-Net address to 192.168.1.64. Then press RETURN.


    At this point, the message is "CodeNet Server waiting for commands". After a few seconds, the screen is cleared and I see "READY".


    I mentioned this on Lemon64 and Tobias responded to say that this is a firmware bug, and sometimes can resolve by reset multiple times. I reset at least 50 times and the issue persists. I still get READY. after a few seconds, no matter what I do.


    Tobias also states that there is an "alternate" firmware available. I read the README file at https://svn.icomp.de/svn/rrnetmk3/trunk/readme.txt. This README states that I must have C64 ASSY 250469 or later to re-flash firmware. Since I have ASSY 250425, I cannot do this.


    Is there any solution?

    Thanks!

  • I still have to investigate why certain C64 board revisions fail to work with RR-Net MK3. This has been on my list for very long, but I cannot say if there will be time for it this year.

  • Update1:

    I have acquired another C64 250425. Same result.


    Update2:

    I borrowed a C64C. Same result.


    Update3:

    I successfully flashed the RR-Net MK3 with the "alternative" firmware which I downloaded from http://wiki.icomp.de/wiki/RRNet.



    With the new firmware, CodeNet starts and displays network activity on the screen, as long as the network activity is not directed to the RR-Net (192.168.1.64).


    As soon as I send anything to the RR-Net, it displays the packet on screen and hangs. RUN/STOP key does nothing. I have to reboot the C64 before I can try another experiment. I have sent several types of messages to RR-Net and they all cause it to hang:

    1. Click WarpCopy "directory". Result is "no reply" and RR-Net hangs.

    2. Click WarpCopy "send server". Result is "unable to send server" and RR-Net hangs.

    3. type "ping 192.168.1.64" in command line. Result is "request timed out" and RR-Net hangs.


  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.