MK2 boots okay but no cursor

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Ideally, you follow the IPC reflow profile: Roughly 3 minutes of pre-heating at 150 deg C, then ramp up to 260 deg. air temperature and make sure that you don't expose the board to this temperature for more than two minutes. I just keep lifting on the chip with tweezers while I apply hot air, and I move the hot air away as soon as I have the chip off.


    Don't force cooling, but let it cool in free air. You should solder the new chip on with a normal soldering iron, not with hot air, as that means less stress for the materials.

  • I have exactly the same problem. Got my MK2 only a few weeks ago and had now the time to test it.

    All CIA´s (3x) I tried works without any problems on original boards Also the other chips. . But on the MK2 i still get no cursor. Ultimate 1541II+ also don´t work. Same problem when the U1541II+ is not connected.


    Kazz: Found a solution?

  • Thanks for answer, Kazz! Good luck with repair!


    What else could be a reason for that behaviour? I am going to test a different CPU tommorow, but if that don´t work, I really have a problem with this MK2 that need to be solved, please.


    I tried already many different setups with diferent chips, none of those chips (CIA , CPU, VIC II, SID´s) make any problem on my original boards. But all I got on the MK2 is a initialized screen without any cursor and without any function.


    Could it be a power problem? I use the 12V power supply which I ordered together with the board.

  • Didn't we have one of these units here for repair? If so, please mention the "iRep" number (three-digit), and I can look up what we've done to make the board work.