MK2 boots okay but no cursor

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
  • My recently purchased MK2 screen went blank while I was setting up a Link232 cartridge linked to my PC. I shut the MK2 power off and removed the link232.

    I booted the MK2 back up and it booted fine just no cursor. When this happens as you know it more than likely a bad CIA chip. I swapped them out and no change. I tried another set and still no cursor.

    I plugged in a diagnostic cartridge and it listed both CIAs as bad. I did this with 6 different chips and the result was the Same. I hooked the MK2 up to term and updated the firmware in case that is an issue. No change. I’m hoping someone could help with this.


    Keith

  • The only reason I can think of both CIAs are affected, but still have VIC-II is if U15 an 74hct139 selector is broken. That same chip also controls DExx and DFxx. So you could check with a freezer cartridge if it can "freeze" into its menu to verify that it still works.


    Just to exclude the obvious though. You did observe the correct orientation of the CIA chips.. right? Notch on the chip on the same side as the metal handle/lever on the ZIF-socket. I do say this, because the text on the CIAs will be upside down, which isn't the way you expect then to go in, maybe.

  • I don’t have a freeze cartridge but I do have The final cartridge III. When I plug it in and turn it on the cartridge menu comes up but the arrow can no longer be controlled by the keyboard.

  • Try moving the CIA chips in the sockets sideways while the lever is closed (lever down=close). This will solve contact-problems that the chips may have. Also, please do the same with the CPU, as that's the chip on the receiving end of the IRQ signal: The CIAs may produce the IRQ signal correctly, but if the CPU dies not see it, the cursor will not blink either.


    Note that every single board has passed QC here before it left. This includes loading software from disk, initiated with a keyboard. Your board would not have the warranty ID if this did not work.

  • I’m not questioning the QC of your board and staff. I own a ton of you products.

    I suspect something shorted when I was setting up the untested link232.

    I have been working with a friend on diagnosing of the problem just like it was a regular c64. I have swapped every chip and tested them in another board.

    I removed the SIDs and booted it, replaced the CIAs, CPU and Vic. We’ve exhausted the limits of what we can do without getting into the board.

    Just looking for some options or suggestions?

  • untested link232

    That might give more hints - was it hot-inserted? Did you do any repairs on that so it works now? Whatever you repaired on that unit might give us a hint about what happened to the CIA chip.


    link232 is a user port device, right? Which signals does it use?

  • The MK2 was off when I inserted it. I was trying to make a connection to a PC using a null modem cable. Tried various baud speeds and couldn’t get the connection. Shut off the MK2 and pulled the link232.

    Have not done any repairs on the link232 yet. Haven’t had the chance.

    Not sure about the signals but I have some schematics for the link if that’s helpful?

  • These diagnostic carts may be wrong - as long as they don't show precisely what went wrong, it might as well be a software error.


    Yes, a schematic would help - I found the Eagle schematic file, but I dont have Eagle installed on any machine (I don't use paint programs, I prefer real CAD software). Can someone convert it to PDF?

  • Ah - so not a user port cartridge, but an expansion port cartridge. This makes Peter's suggestion for exchanging the HCT139 (U15) more likely. That's a standard part, just in SO16 package. I guess if you can find a shop that still sells TTLs, they may even have the SMD version in stock.

  • I just ordered a few of the 74HCT139D Should be here in a few days. I will keep you updated on the results.

    Anything special I should be concerned about while changing that chip?

  • Anything special I should be concerned about while changing that chip?

    Remeber that the board is produced RoHS compliant, so the melting point of the solder is higher than you may be used to from other hardware that has been produced pre-2006. It may take awfully long to melt the solder with hot air, but that should not make you impatient - it's tempting to increase hot air temperature, but that may have negative effects on the glue that holds the copper on the FR4 material (i.e.: pads rip off if you pull on the chip too hard).


    In short: Take your time, don't apply force. Tiny tools, very little force.