ACA500Plus and df0 disabled: Is this a bug?

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
  • Hi guys,

    2 years ago I bought the fantastic ACA500Plus, but due to my work commitments I was able to use it only a few times although without any probkems.

    After a pause of over 1 year, in the last weeks I decided to handle and reuse my Amiga again along with ACA500Plus.

    After playing some game I decided on using ACA500Plus with CF cards as HD, but before proceeding, I decided to upgrade the firware to the latest ones released (Menu system V0.127 + Installer V1.1 + HRTmon update), but as soon as I did it I started to experiment some problems with df0 internal unit of my Amiga 500..

    I suppose something went wrong or probably some bug or conflict arised or some setting has been set badly, because since then df0 remains constaintly disabled and my Amiga automatically use df1 external drive as df0 (I hear the "click" noise only from df1 and not from df0). Floppies start loading only from df1 and df0 ignores them when inserted in. :/

    I tried unplugging external drive but df0 results as dead (no click from the hardware). It returns fully working only when I unplug aca500plus from the lateral slot. But If I try to connect it again then df0 returns to be as dead, ignoring any floppy inserted.

    I tried to reset the ACA500Plus settings from menu and I have also checked if among the settings the df0 unit was set as disabled, but it results enable... so what is happened? What do you think?

    Thank you for any tips.

    Regards from Italy.

  • This sounds like you have activated the "boot selector" feature, which swaps df0: and df1:. However, it's hard to do so by accident - please check if your computer has a physical switch installed, because such boot selectors were popular back in the days.

  • Dear Jens,

    Thank you for your reply.

    I confirm that the problem is probably due to ACA500Plus, and it started with the last firmware updates. I do not have any switch installed inside my Amiga.

    Just to be 100% sure that is a firmware problem, could you indicate to me where I can download the oldest firmwares?

    I would try to restore a previous version and focalize the source of the problem.

    I am quite sure that my issue could interest your technical staff.


    I look forward to receiving your indications.

    Regards and thanks.

  • Just in case: Please go to F8 boot selector option, turn it ON, save the settings and power cycle the computer. Then go to the same menu, switch the boot selector option off again, save settings and test if it works correctly (assumption here is that there's an error in the saved data).

  • I restored V0.125. I went to F8 page and in corrispondence of number 1 (as option to click) is written DF0: override with a "-" sign.

    When I click 1 again other options are only "Empty" and "DF1: Bootselect". Is this the "F8 boot selector option"you are referring to?

    I would exclude that is a problem of my df0 unit for the simple fact that it is automatically disabled only when ACA500Plus is plugged. When I unplug it df0 returns fully working.

    It seems more like something would make a conflict. Could it be that my ACA500Plus is damaged? But it never fallen or beated...

    I can assure that the problem arised since last firmware update.


    Anyway, just to be sure that is not an hardware problem: at the same way of mobile phones is there a secret function or menu inside ACA500Plus that allows to test if the device is fully working? Or that allows to test all its functionalities?

  • Another thing I noted If I visit the section "Normal Mode Expert Menu" (F10):

    Supposing I have also DF1: unit plugged to my Amiga I see on the right of the screen:

    0 DF0: Enabled

    1 DF0: Enabled

    2 Df2: -

    3 Df3: -


    I noted that if I try to cycle the options of Df0 clicking "0" number I see only in sequence:

    Enabled

    Empty


    Conversely, if I try to cycle the options of Df1 clicking "1" number I see in sequence:

    Enabled

    Disabled

    Bootselect


    The option "Bootselect" appears only with df1 and not with df0.


    I hope that it can help.

    Thank you for any suggestions.

  • Anyway, just to be sure that is not an hardware problem: at the same way of mobile phones is there a secret function or menu inside ACA500Plus that allows to test if the device is fully working? Or that allows to test all its functionalities?

    There is no diagnosis mode or so, but if you want to exclude the menu software as your source of the problem, just (re-)launch the computer with de-brick mode enabled. However, the procedure will have to be a little more elaborate, as the drive swap feature is NOT reset with a keyboard reset, but only with a fresh power-up. You'll need quite a few fingers and maybe even need to flick the switch of the PSU with your toe:


    1) press and hold CTRL-Amiga-Amiga and the DisMo button all at the same time

    2) power on the computer

    3) wait until the "0_" shows on the DisMo

    4) release all pressed keys/buttons


    This will keep the unit from executing the menu software, so that can't mess with the drive swap/disable registers. You should now be able to use the drives without any swapping/disabling. A single press on the DisMo button will end the de-brick mode, and the next reset will bring up the menu again.


    That's intentional, because the Amiga cannot fully disable df0: - the system just assumes it's there, because there is no Amiga 500 computer without a disk drive. The only way to "disable" df0: is to make the system believe that there is no disk inserted. This is different for all higher drive numbers, as these have a presence-detect-circuit which the ACA500plus can intercept.

    The option "Bootselect" appears only with df1 and not with df0.

    Also intentional, as df0: is the normal boot medium - there is no point in specifically making this the highest-priority boot menium, because it already is. The "Bootselect" label merely means that df1: takes the place of df0:, which is indicated by teh "bootselect" label.


    So whatever is set for the two drives, please set the opposite, save the settings, power cycle the computer, set everything back to normal ("enabled"), save again, power cycle and see if it made a difference (this was yesterday's suggestion).


    Jens

  • Hi Jens,

    thank you for all the clarifications.

    I performed two tests to be sure, once again, that is a problem due to the last upgrade consequences.


    The first is the one you suggested above resetting through CTRL-Amiga-Amiga and the DisMo button, and yes I confirm that without loading/displaying the menu the df0 works 100% (along with "click"sound).

    The second was a bit raw and risky test, in fact I opened my Amiga case, I removed the upper part of the case. I turned on Amiga and selected from ACA500Plus menu a choice (eg. Kickstart 1.3). After that screen returned to classic hand with floppy (and in my case along with the df0 unit not working), I unplugged the power connector of floppy unit from Amiga motherboard for 1 second. When I plugged back it then df0: returned to work.

    It seems that something in the firmware of ACA500Plus paralizes or is in conflict with Amiga's controller of df0 unit.


    In any case, looking at the result of the test you suggested (CTRL-Amiga-Amiga and the DisMo), what is the best way to solve the problem regarding the menu? Because at this point I assume that the problem arises from a bug or a bad upgrading of the firmware, right?


    Thank you again for your precious support. I hope that this topic can be useful to other users as well.

  • While the de-brick-start test givesa usable result, the other test you've done (unplugging df0: power for one second) gives a totally unexpected result.


    There is no such thing as a "df0: controller" or a "df1: controller" in the Amiga. The controller is always the same, and only the select-lines differ. So if your drive works one time, and doesn't work another time, a CIA chip may actually be at fault. Please try to exchange the two CIA chips for each other and see if there is a difference.


    And yes, the firmware may make a difference, as detecting drives involves serious bit-banging on the CIA registers. If I remember right, the drive detection routines have been worked on in one of the past updates, and this may actually trigger misbehaviour in a defective CIA.

  • Dear Jens,


    I tried to swap the 2 chips and the problem remains... with ACA plugged the df0 does not work. Unplugging ACA the floppy disk drive returns to work.


    I will make a last attempt with an Amiga 500 of a friend of mine, if the latter should confirm the problem I will contact you by email to plan a repairing of the device.


    At this point I wonder if the problem is really in a bug of the firmware or in some chip on ACA's PCB that probably has been damaged... but in this last case how it has been happen?

  • I'd love to have a clear explanation for all kinds of effects that people describe in customer support. It's not always possible :-) Partly because observations are sometimes vague, or (in this case) the topic is kinda complex, and you just quit spending time on something when a fix is found. Let's focus on that for now.