Problem with ACE2

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • I have just gotten the ACE2 AGnes RAM expansion.

    Computer: Amiga 500 r6A with 512K on board and card with additional 512K, Vampire v500 2+, Gotek, Denise USB keyboard.

    After installation I get the normal lights and first boot screen from the Vampire. After that no signal from either the Amiga RGB or the HDMI on the Vampire.

    I removed the and replaced both the Gary and the old AGnes, same booting now.

    Question is where is the fault:

    • The ACE2? but now the old setup doesn't work
    • The motherboard? everything else appears to work
    • The Vampire? are there reports that the ACE2 doesn't work with it? All the lights an the Vampire are on.

    Any help or suggestions?


  • You probably have a bad Agnus socket. Please inspect all pins, maybe bend them a little inwards, then both setups (with and without ACE2) will most likely work.

    The on.board chip ram and the trapdoor expansion are disabled when ACE2 is installed, and automatically re-enabled if you use a standard Agnus chip.

    Although Vampire does have it's flaws, it certainly works with 2M chip ram expansions.

  • I don't have the eyes anymore to get in close and check the pins...

    Get some reading glasses :-) Has helped big time for me.

    We do test every single unit for proper function, and problems mostly arise from contact problems between the Agnus socket and the adapter socket of ACE2. Sometimes it just helps if you clean the Agnus socket with IPA and an old toothbrush, then re-insert ACE2 while it's still wet.

  • OK I went the easy route (not really) and got a new A500 6a mobo. This time I didn't put in the Vampire and just tried it first without and then with the ACE2. Same thing happened and now the mobo won't boot with the original Agnes (sigh...). So I now (finally listening to you...) got my reading glasses and will try cleaning out the socket with IPA and a toothbrush, gently I presume :-)


  • Glad got it working...what did you do...?

    Clean and reinstall...?

    A600 Furia with 020/33 9.5 meg fast...32gb SD...Pi1 Dfo: Geotec DF1:....A604n...Indivision V2...RTC....Prisma card Wirless Keyboard

    A500 rev6a project

    Xbox Classic with WinUAEX

    Rasberry PI3/Amibian

    Dell Laptop Winuae

  • Hi Phil here from Australia:

    Just a question about ace2 I have just bought Amiga 500 rev 5 with 512kb memory and a 512kb expansion boardif i buy the ace 2 will that give me 2meg chip with out problems:):):):):):):)

  • I have just bought Amiga 500 rev 5 with 512kb memory and a 512kb expansion boardif i buy the ace 2 will that give me 2meg chip with out problems

    The trapdoor mem expansion can even be removed, as the complete 2M of chip ram are on ACE2. The only reason to keep it in the computer would be an RTC on the trapdoor expansion. The memory part of it will be disabled by ACE2.

  • Was also wondering if you could recommend a SCSI 2 card for the Amiga 500

    These are not made any more - for good reason. You can't buy SCSI harddrives any more, and those customers who still have an old SCSI controller are looking for SCSI->flash card adapters. So why not look for a thing that lets you use flash cards without adapter?

    The ACA500plus allows that, and much more. Please read through the product description and if you still ahve questions, please open a separate thread in the right part of this forum ("accelerators").

  • Hello

    A question. I bought and installed the ACE2 card on my A500. It works fine and gives me the full 2MB. Great. However, I've noticed some occasional graphics corruption. Downloaded memtest from Aminet and it reports broken memory addresses. I'm not sure I really trust the program, and I've tried to load some really large Soundtrackermodules that generally only use chipmem. They work fine. So I don't know if it's a real problem or not.




  • All ACE2 that leave here have passed QC, which includes a memory test. The best test I've found is the "MBRtest-2" by Microbotics (was supplied with their memory cards back in the days). Further, if the computer shows 2MBytes of chip ram, it has passed a basic memory test already, otherwise the Kickstart would not make this chip ram available.

    If you only get gfx corruption but no system crashes, I'd look for a contact problem between the socket and the socket adapter of ACE2. This is very common, as the Agnus-sockets that Commodore has used are around 30 years old and not the best quality available. The first step would be to clean the socket and the adapter with IPA and an old toothbrush. Further, please check especially the corner pins of the Agnus socket: Are the pins pushed outwards? This happens often if you remove the chip. You can carefully bend them inwards again, but this MUST NOT be done from the top side, but ideally from the bottom end of the pin.