Buddha IDE and TF534 card

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
  • Hi, anyone has experiences using a Last Buddha ide card with an accelerator TF534 on a A2000?

    There is any conflicts between the ide ports?

    Can be the autoboot disabled on the Buddha?

    Thanks

  • I have no idea how that TF534 accelerator makes it's IDE, but it really should not conflict with the Buddha, because the Buddha makes a clean auto-config. No software should interfere with the resources assigned by the Amiga OS to the Buddha card.


    The best way to "disable" autoboot is to either reduce the boot priority in HDToolbox, or to un-tick the box "bootable" in the extended/expert settings of each partition (again, in HDToolbox). This is all Basic Amiga usage, nothing special about the Buddha.

  • Hi Jens. Thanks.

    As usual your hardware is the best.

    I wish to have the chance to buy the accelerator for my A2000 from you. Unfortunately the TF534 is the best stable alternative around for the A2000 but only with 4MB, I don't know why those people stuck with 4MB on a 68030. Otherwise, only overpriced old hardware.

  • Hi, unfortunately not.

    I didn't bought the Buddha yet because I still don't know if there is any problem.

    I do know that the TF works with the GVP series II but because the TF has a non DMA memory, it slow down a lot.

    I don't know if the Buddha have any needs about DMA or special hardware use that the TF can't supply.


    Regards

  • Hi, I finally decide to buy the Buddha and test it. Unfortunately, in opposite of Jens and mine hopes, the TF534 ide interfere in some way with the Buddha. I really hope that Jens can drive me to a solution because there are a lot of people with a TF (unfortunately Jens still haven't done an accelerator for A2000/A3000/A4000 people) that need a better HDD/CD solution and in have to go back on SCSI and all the trouble that it give, especially for cd/dvd. The behavior of the Buddha is very weird. So I list the tests and their results in order to make a clear (as much as possible) scenario to whom want to help to solve this, if it is possible:



    My config, that is amazingly working form a little while now is:

    A2000 rev.6.2 PAL, 1MB chip, Kickstart 3.14, indivision ECS v2, GVP Series II 8MB fastrom 4.15 SCSI to IDE adapter and CF 16GB, TF534 with idetocf and CF 32GB (dh0 1GB,Dh1 16GB,DH4 15GB), gotek drive.



    Unfortunately the TF ide is not one of the best especially on writing and because the TF that have 4MB of non dma memory, my GVP is slowed down too. Plus my scsi cd is dead. So I tried to solve this with the Buddha but.....



    First of all I want to be sure the the Buddha works, so I pulled out the TF, disabled the Boot of the GVP and put back the 68K. I still need the 8MB on the GVP or with the AmigaOs3.1.4 I can't do basically nothing. Trying anything less than 3.1.4 make no sense for me.

    To be sure that all is ok I flashed the Buddha with the last firmware on the icomp website.

    Booting from 3.1.4 install disk, buddha show up the DOM content and scanning with hdtoolbox (modified to read buddhascsi.device) it show the 60 GB ide (master) hdd attached. Partition OK, Install 3.1.4 Ok, boot from it ok. Sysinfo4 915MB/s

    Very far from the 2.2MB/s of my GVP (but close to the 1.3MB/s of the GVP because THe TF534)


    Removed the DOM and the jumper, attached on the second port of the Buddha a dvd ide(master) and configured cd0 for buddhascsi unit 2, put cd0 in dev/dosdriver and it works.


    At this point I start experiencing strange fault, like as soon I open a drive the A2000 reboot and give me a guru error 8000 0004 task 002ac2e8 but the task number vary.

    or "workbench program failed (error #800003). wait for disk activity to finish" and all stuck.

    I had in the past this problem and it was when some hardware had problem with the GVP memory.

    I pulled out the GVP and the error is gone, but with 1MB I can't do anything.

    Next test I swapped the HDD 60GB with a CF2IDE and a CF 16GB and all is ok like with the HDD sysinfo 665KB/s.

    Now a CF of 32GB same brand and it is ok. sysinfo 722KB/s.


    Having a working Buddha now I have to hop that it works with the TF534, at least I can have 4MB.

    At this point I pulled out the 68k and inserted the TF with no CF.

    No boot at all, the boot sequence not even start. Nothing from Buddha, nothing from TF, nothing from FDD.

    So I detached the DVD and I received the Kickstart screen. Good, now we have the A2000 start but seems not recognize the HDD.

    Now I want to try inserting the DOM.

    Incredible the DOM booted, I got HOPES.

    I select install and.... the buddha can't see the Hdd. OH my.

    Put the CF on the TF and try if it boot. And it boot.


    I have the icon of the DOM and works. But both installBuddha and HDtoolbox can't see the hdd.

    I swap the hdd with the CF16GB and Nothing. I put now the CF32GB....nothing. The only thing that the Buddha can see is the DOM. So I move the DOM on the first ide port and enable the jumper. At the reboot the DOM is present on port 0. I open the jumper on the second port and test all the previously working stuff (hdd and CFs) but no luck. Now I attach the DVD and .. Oh GOD it works.

    Installing the software at each startup Buddhaspeed set the timing on 0.

    Finddevice can find only the DOM and the DVD. Tested with all the previous stuff.

    So may be it see the DOM because is small, Ok let try a CF of 64MB, smaller than that is impossible.

    But no boot again. Let detach the DVD.

    It boot again but finddevice and HDtoolbox can't find even the CF 64MB.

    Jens on this forum said that because the bad timing of an accelerator you can have some strange issue like not being able to flash the buddha. I tried to flash it with the previous version (the one on the DOM) and all seems fine and then I flashed it with the new one and again no problems. This may mean that the timing is almost correct, so why it doesn't work properly?


    I really need the cd/dvd to move files between the amiga (2000, 1200 and 500) and pc but I can't give up the 8MB of the GVP because the Buddha seems allergic to it and it can't be properly used with the TF, I have to sell the card and buy a SCSI DVD if no solution are found.


    I hope that there is a solution for this. I hope Jens can help and I will seek for help in other place too because I believe that TF534 and may be TF536 or TF560 next to come will need more ide ports and the buddha can be a good choice.


    Sorry for this novel, I know it is a little bit long.

  • I have an Amiga 2000 with no keyboard. I just purchased a Buddha and can't test it yet because my Lyra 3 hasn't arrived yet (I didn't buy it from Jens, my mistake). My A2000 has an Adram 2080 RAM card with 4/8 Mb populated. I have an IDE to SATA converter and my goal is to set up a small 120gb sata ssd as the main drive.


    I'll post back compatibility with my setup once I have this up and running - I'm hoping the Lyra arrives sometime before the weekend.