ACA500+ stopped working (E5)

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Dear team,


    I own an ACA500plus and today it stopped working on me.

    History: I have never had any complaints so far but last weekend when I had the Amiga in a Retro-Console-Event-Room I was informed that my machine would not boot properly anymore. So I checked and they were right. All it did when I arrived was booting into a frozen white screen or into an E5 error with black/green lines all over the screen. To prevent any damage from curious guests, I wrapped everything together.


    Today I set up the Amiga back at home to test and it instantly worked (but only for a while). I was in the ACA500plus menu and it looked good at first.

    To test it all, I booted my Workbench from CF (worked). Then I started the machine from disk (worked aswell). But at some soft-reboot, using the Amiga keys it started coming up into E5 error with black/green lines again.


    That is how it is now. Every time I plug in the ACA500plus, it only boots into E5.


    The error:

         


    Without the ACA500plus it is working just fine:


    Can someone please help me?

    --------------------------

    ... ich bin der Jäger des Mondes, bis der Morgen erwacht!

  • Dear Jens,


    thanks for the advice. I did everything you said. I Ordered IPA cleaner, wiped the A500s contacts with a micro fabre cloth and brushed the aca500+'s contact with a toothbrush.

    The issue remains the same

    --------------------------

    ... ich bin der Jäger des Mondes, bis der Morgen erwacht!

  • Then we'll have to take a look at it here. Please send it to us, and please also include a short letter, so my employees know what to do with it.

  • Hello Jens,


    I'm having the exact same problem as hthnightwolf except that it hasn't recovered from the E5 error at all.


    I've had the ACA500plus for about 2 weeks and it has been flawless until now. I was simply working within the stock 3.1 Workbench and the screen went black with the E5 error on the card.


    I'm assuming that it's the same issue as above?

  • Well, if you have the *exact* same problem, and "all of a sudden" the unit does not work any more, then someone has plugged it in upside down - without you knowing of course.


    And the protection curcuit has kicked in: The "resistors of shame" are now burned, and they need replacing. We can do that here, or you can have someone do that locally. Warranty in that case is lost anyway, so it's up to you to decide who shall do the soldering.

  • Jens I'm afraid that I have brought shame upon myself by hastily plugging the aca500 in upside down. Can you please let me know which resistors I need to swap? Thanks.


    EDIT: oops, nevermind I found the silkscreen pointing to them near the edge connector.

  • "resistor of shame" exchanged - card was installed upside down. Invoice sent via eMail.

    Hi Jens


    I have got an aca500plus from somebody and they said they had plugged it in upside down, you have mentioned resistor of shame replaced would it be possible to find out which resistor that would be and the value please as it card if way out of warranty as the broke the cf card slots on it so just trying to get it running before i attempt to rectify the missing slots, any help would be greatly appreciated.


    reading down the posts i will have a good look at the board tonight and see if i can find the resistors in question and will order some for replacement, i look forward to resurrecting this as i've always been a fan of your work and had many things for my a1200 in the past from you.

  • Ony the newer ACA500plus with the "big Dismo" have these resistors. They are located in the corner where the Boot CF-slot and the 86-pin connector meet.


    On the older cards with small DisMo, the 9572 CPLD and the DisMo need to be exchanged in case of installing it upside-down.