Amiga SD Project (just as good as an USB)

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • I have been working to save Amiga files on to a SD card from a windozzz pc to the Amiga. You need Fat95 program and a Mount file. A SD2IDE adapter and a SD card 1 or 2GB. When you order a SD2IDE adapter, do NOT get a micro-SD they are easy to lose.

    I am using a buddha IDE card in my A3000D/T, I use the BuddhaDHToolBox make a copy of HDT00lBox and rename it to BuddhaHDToolBox in the info file, Icon panel change the scsi.device to buddhascsi.device and save. On my A1200 I use HDtoolBox which uses the scsi.device.

    Amiga ASD Project.

    ASD stands for Amiga Secure Digital the SD card.

    This is as close to having an USB thumb drive to store and transfer data from a windozzz fat32 file system SD card without having to make special hardware. All the hardware is cheap and available on eBay. SD2IDE or SD2SATA with power connector about $18 USD.

    If you have a spare IED port on your Amiga and don't want wires hanging out the back of the back, please see my Amiga eSATAp projects.

    At this point I will assume you have an eSATAp connector on the back of you Amiga or you have the card plugged into your IDE port. I have an SD2SATA with power connector on order.

    The SD card adapter will be external so I can move to my other Amigas so not to alter the Amigas case. On the A2000, A3000D/T and A4000 it is possible to install the adapter inside and with a SD ribbon cable extender it can be mount in front of the Amiga with a piece of plastic and a rectangle hole to epoxy it into place The A1200 there is no room. Do not alter any Amiga any part they are difficult to replace. The only software is Fat952 on, or search for Amiga fat32 and download and install it. It's included in the attached file).

    On your workbench make a directory Mount ASD, make a copy of PC0 in your Storage folder and put it the ASD folder rename it to ASD.

    Important, use a 1gb SD memory card, the smallest I had was a 32MB and a 2GB card and they both worked on my A3000T.

    On the Amiga you can make one partition for size of the SD.

    Connect your eSATA cable to the SD2SATA adapter insert your 1 or 2 GB SD Card and Bootup you Amiga.

    My IDE ports are using the buddha IDE from icomp. Click on HDToolBox, make a copy and rename it to BuddhaHDToolbox and save it.

    click on it and go to information and where it says scsi.device change it to buddhascsi.device and save it.

    Open up the BuddhaHDToolbox and you will see your devices. The top one is your boot device the other will say Unknown. Note the Address Number, click on it, Change Drive Type, Define New, change FileName to ASD, enter, Read Configuration,

    it should be FC-1307, SD to CF Adapter, the Size should be the same size as your SD card, if not go back and recheck your drive selection. If it looks good then click OK, Continue, click Ok, the FC-1307 SD to CF Adapter Rev should be in the panel click Ok,

    and Unknown should change to FC-1307 SD To CF Adapter Rev or similar, next select Partition Drive, Delete Partition, change it to use the full size of your SD card.

    Change Partition Device Name to ASD, do NOT make it Bootable. Click on Advanced Options, Change, change to Custom File System, Ok, go to Add Update, Delete File System, Add New File System, change it to L:fat95, Ok, change Enter DosType for File System to 0x46415401, Ok, Update File System, should say L:fat95, the Dos Type should be 0x46415401 greyed out Ok, then Ok, then Ok, Save Changes to Drive, do NOT Low-level Format the drive. Save it and exit.

    In your ASD folder left click on ASD and go to Information, Icon, add the following script.



    Unit=2 (your number I had you remember)










    Save it and reboot. Click on ASD and a disk will appear, Name it, ASD, Quick Format, remove SD card and insert it a windozzz pc. It should pop up with Trashcan and the info files, if not then format it using default.

    and name it, ASD, open ASD and copy a few files to the ASD device. Insert the SD card back into the Amiga and reboot. Click on your ASD folder click on ASD and the ASD disk should appear with some files in it.

    You can delete all except System Information, windozzz may need it. Now your all set to copy files from your windozzz pc to the SD card. Put it back in your Amiga and reboot. Open up the ASD disk and load the files on your Amiga. On the Amiga if you remove the SD card and reinsert it will hang the Amiga, I don't know why but the OS may not see a Disk Change.

    If you have any problems let me know.

    I did a SysInfo V4.4 check and it was as fast as the HDs speed.


    Frank Papaeliou

    Idaho U.S.A.

  • Note: On the A1200 I need my adapter to show up before I can confirm this will work on it.

    I will keep you posted. It does work on the A3000D/T using the buddha IDE.

  • I made some errors on the file name it is fat95 NOT fat32 or fat952 and the custom filesystem is L:fat95 in the buddhaHDToolBox the fat95 must be in the L: folder. The files you need are in the ASDProject.lha above.

  • I know that Fat95 does not use write-buffers, so in theory, this setup should support hot-plugging an SD-card. Does it?


  • Jens

    It works great hot-plugin while the Amiga is booted but not mounted, the only issue I have is when I unplug the SD card and plug it in again it hangs up the Amiga, that's why I stated that a reboot needs to be done. I tried KillDev and DiskCng with no success. What senses the disk change, the adapter or the Buddha? As far as copying files between PCs it works great. The Unit number on the SD adapter is 2, it's plugged in the right IDE. Any ideas would be nice.

  • the only issue I have is when I unplug the SD card and plug it in again it hangs up the Amiga,

    That's what I mean by "hot-plugging" - so the answer is "doesn't work".

    Try "assign unmount" before removing, maybe that works.

    As far as copying files between PCs it works great.

    Not as good as networking :-)


  • Jens

    Ok I will do it.

    I logged in to your store and searched for AmiTCP went to de/shop/product/amitcp-install-disk-adf-not-logged-in.html and got an error message. it was in German. I did not see a place to buy it, I did see the new Buddha, nice, you say it's faster what is the transfer rate bps, why the CF card I know that other Amigas use it but isn't that going backwards.

  • Quote

    I logged in to your store and searched for AmiTCP went to de/shop/product/amitcp-install-disk-adf-not-logged-in.html and got an error message. it was in German.

    Are you sure you were logged in? The link pretty much says you were not :) (And then you can switch the shop to english, of course - and the message will be in english too)

  • Tiobias

    Yes I did login, I will try it again. I did switch to English but the error message was not.

  • The page has changed I was searching for AmiTCP and it found it showed me where to downloaded now it's not there. It brings X-Surf 500. I have an A3000T 68060-50.

    I am on both the Store and the Forum.

  • Jens

    This what I get when I click on the link you provided.

    Houston, We Have a Problem!

    Edited once, last by A3000T: After looking at my orders I have bought this 09.01.2023 Order#127341 Hold off on this order until I check my files. ().

    • Jens
    • After looking at my orders I have bought this 09.01.2023 Order#127341 Hold off on this order until I check my files.
    • I have looked at all my disks and can't find the AmiTCP that I received from you. Do what you need to do to get me AmiTCP.
  • I can see that you have bought AmiTCP with order ID 143291 yesterday evening, and you've downloaded the file a few times, so I believe you've installed the stack by now?


  • No, I have not had time to install the stack, I have been busy on other projects of which is getting my HP 6L laser printer, Epson Stylus 740 color printers working for my Amigas and cleaning snow from my driveway with my tractor and running a CAT6 cable to my Amigas as they don't have WIFI, yet that sounds like a job for you and icomp.

    The reason for the 3 downloads was I got a download error message, so I tried the download until I got a good download.

    Did you see that I ordered AmiTCP in 2023 and did NOT make any download! This was during my illness with COVID and was laid up, I didn't know where to get the downloads, it was not mentioned in my purchase, so I forgot, I had other pressing issues like getting well.

    You mentioned a unmount command, I can't find any mention of it in any Amiga commands, I checked my OS3.2 and it not there either.

    Are you making the unmount command up?

  • Jens

    This is info "" from user fgh "CD / SD and large drivers FAQ" that I came across about the Buddha IDE. Was there a fix for this in your updates?

    Removable vs fixed flash media (short version)

    Original scsi.device IDE drivers works well with both fixed and removable type CF cards.

    The Amiga PCMCIA driver compactflash.device also works with both types of cards.

    Some CF cards do not work with compactflash.device, but this is for other reasons.

    IDE drivers confirmed NOT working with removable type CF cards:

    IDEfix (Elaborate Bytes)

    Buddha (Elaborate Bytes/Individual Computers)

    XSurf (Elaborate Bytes/Individual Computers)

    Catweasel (Elaborate Bytes/Individual Computers)

    When loading these drivers (usually during boot) with a removable type card, the amiga will hang/freeze. (This is what happens on my Amiga)

    Doobrey has made patches for IDEfix and the other Elaborate Bytes IDE drivers, that correctly identify CF cards, and allow removable type cards to work correctly.

    SD cards are neither removable or fixed in themselves, as they are not ATA devices.

    It's therefore up to the IDE-SD adapter which response is given. (Examples under 'Clever SD-IDE adapters' above.)