C64 Reloaded MK2 Not Appearing in OSX Serial

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
  • Hi


    I bought a reloaded mk2 (Order 33444) and it has sat in the box untouched since then. I decided the other day to start it up. I have used an old c64 for chips and some NOS ones. But when I switched it on it blinked red (and the d46 light blinks). So I went to debug via the usb serial port but it isn’t listed in the Mac app serial. I’m not sure what is wrong or what to do next?


    Al:(

  • Can you check the ICs in that old C64? If so, please do. Then, some IC could have bad contact in the ZIF socket - try pushing them gently left and right and wiggle them a bit. Perhaps that solves the issue already.


    As for the MK2 not showing up in OSX... i am not familiar with macOS, so... all i can recommend is powering on the MK2, then attach the usb link to the Mac. it should get detected then :) If not, do you have a way to try on either windows or linux? (linux would be easiest, as you can see in the system log if the USB device is alive)

  • Hi there. I have wiggled them. I also have bought another working donor C64 and have now tried 2 different SID's, 4 different CIA's, 3 different CPU's, 2 different VIC's etc. And the red light flashes, it still doesn't show up in 'Serial'.


    I really need help. What is the process of firstly knowing that the board itself is not defective? It is greatly suspicious that it does not show up in 'Serial'. When it should.


    The fact that no combination of chips brings it to life is also not good.


    What can I do to debug the problem. It is clearly more than just a bad contact?

  • MacOS drivers from Prolific are truly bad, and you see frequent rants about that on the internet. THere's a terminal program that can talk to the USB chip directly, the name is just "serial". While I do not recommend to buy it due to it's non-working XModem support, the free version will at least be able to show you the remote control menu:


    https://www.decisivetactics.com/products/serial/


    The mere fact that the two LEDs do blink shows that the MCU on your board is working, so that part is already known-good. We do have a fairly long list of things that are checked during QC, and every single board must pass this list before it gets it's warranty ID. Without checking the database for details, I am very sure that your board has passed QC and is to be rated "known-good".


    One thing that you haven't mentioned is the source of your USB cable: Could it be that this cable is a power-only cable? There are cables that are meant for charging only, and they do not have data lines. Hard to see from the outside, and due to the small connectors, even harder to measure. A simple change of cables could already do the trick.


    Please also mention the type of PSU that you're using. The power supply does have an influence on the chip recognition part.

  • Okay some progress given your helpful comments!


    Serial: I had already bought the terminal program "Serial" but it wasn't showing in it

    PSU: Is a Ktec. And I bought it based on the spec you give at http://wiki.icomp.de/wiki/12V_DC_power_supply

    See attachment


    USB Cable: You were right! Must have been a power only cable, as I've switched to one I had from an external hard drive and then it appeared in Serial although with a warning I should delete a "Prolific" driver which I did. I can now access the menu. Progress


    So the menu is saying:


    Error: VIC-II is not recognized, check U19.


    Even if I change the VIC (I have an 8565R2 & a 6569R3) it doesn't change that message


    If I press "I" it says


    VIC-II: Unknown (D9 D9 0000 PAL)

    SID 1 : 8580 (FF 00)

    SID 2 : Unknown (17 00)

    CPU : Unknown (08CA)


    Now weirdly it's thinks that my 6581 SID is an 8580. I also have an 8580R5 which if I put beside the 6581 in SID #2 it then reads:


    VIC-II: Unknown (D9 D9 0000 PAL)

    SID 1 : 8580 (FF 00)

    SID 2 : 8580 (FF 00)

    CPU : Unknown (08CA)


    I have 3 CPU's 2 6510's and 1 8500. They are not detected.


    I have tried changing the CIA's (I have 4) in various combinations.


    To no avail


    What do I do now?


    Kind thanks
    AL

  • Please remember that yesterday was a holiday in Germany.


    Next step would be to measure the PSU under load. Connect the PSU to your board, switch it on and use a mount hole as GND pin. Then measure on a few points:


    - at the power input

    - at pin#28 of the SID (that's "top right")


    One thing I didn't mention yet is that some people use the ZIF sockets the wrong way round, and I've seen it even in a Youtube video: Closing the sockets means that the lever is "down". Before inserting the chip, the lever must be "up", then you drop the chip into the socket and push the lever down. For best contact, you can slide the chips sideways while the lever is down (this does require a little force). This will scratch the pins on the contacts, removing a possible oxide layer that may have built up over the years.

  • That's really on the far-low side. Before I jump to conclusions, please remove the VIC-II chip and measure on pin#28 again. Does the voltage come up into the area where we'd expect it? (i.e. 8.5V)?

  • No need to be sorry - you've bought a product and deserve the required service to make it work.


    All I can see is that "something" with the voltages is not right, and the values you've posted really point to a hardware defect - either on the board or with the power supply. I fear that there's not much left for a diagnosis from a distance. Next step would be to pack it all up and send it to us - if there's a fault, we'll find and fix it. Please include chips and the PSU, so we can test the exact same setup that you're having trouble with.


    You can find the company address at the top of your invoice, or in the "Impressum".

  • Hi


    I’ve shipped it all to you. PSU & Chips and a Euro plug adaptor! It will arrive with you on Thursday. Sorry it has taken me so long to report the issue. I bought the board from you in January but I’ve had no time to try it until the past two weeks. It sat untouched in the box.

  • Some return arrived friday afternoon, but the workshop staff made a "short friday" that day. We have a policy to only open parcels with a witness, so please wait for the shop staff to be back at work in about 11 hours.

  • Hi,


    your box was unpacked today, and we've all screamed a loud "NOOOOO!" through the shop. You've managed to put each and every chip the wrong way round into the sockets, completely ignoring the instructions and photos of the coloured instruction sheet,


    You did not include the instruction sheet with your parcel, so it's still at your place. Our photo documentation shows that it was in your box, and you also have access to it through the Wiki.


    We'll now check if any of the chips has survived.


    Jens

  • The good news is that the computer starts and works if all chips are inserted the right way. I won't go as far as saying that the chips have survived - they may have suffered long-term damage. Since the application "C64" is nothing really critical, I'd enjoy them while they last.


    Your CIA chips do have a funny print on them, with date codes that are beyond anything plausible. One of them is supposedly made in week 00 (which does not exist) of the year 2035. The Chinese obviously take chips and re-label them to make them appear more valuable, but I wouldn't have thought that they pretend to have a time-machine :-)


    Anyway, I'll contact you through e-mail with a request to pay for shipping the board back, as this is clearly a user error, not covered by warranty or standard customer support.

  • Please contact me for the shipping cost as soon as is convenient. I’m really confused about the chip insertion. I don’t think I was doing anything wrong so I’ll be fascinated to see what you did. Are you saying some chips were in the wrong way?


    Which chips do you think may be damaged? All or just some?


    Both those CIA chips I bought from a guy in Germany. So that is weird. I do have others. I look forward to receiving the shipping payment link


    Kind thanks