INDIVISION ECS V1 GHOSTING

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Dear Jens

    Im experiencing Ghosting with my original ECS flicker fixer on my a600. Any news how to fix the ghosting? I was interested in buying the v2 for my a500 but i want to solve this issue first, since i don't want to end up with a similar problem. The A600 was tested on a 15khz BENQ monitor using the RGB out of the A600 and no Ghosting were noted. The problem happens only when i connect the VGA out of the Indivision ECS to ANY monitor.


    Replies are greatly appreciated for any possible fixes.


    thanks

    Carlo

  • carlo

    Changed the title of the thread from “INDIVISION ECS V1” to “INDIVISION ECS V1 GHOSTING”.
  • For the V1 version, there is neither an open case, nor any reports of ghosting that may need fixing. As after almost ten years, you're the first to report a problem, I'd suggest checking your cable.

  • Hi,


    I changed the cable and problem persisted. Is there possibility that there is a faulty component/filter that needs replacement? IS it possible to get another Indivision VGA ribbon cable maybe its the problem? To tell you the truth only recently i noticed this problem (circa 4 months ago)

  • Indivision ECS V1 has been out of production for over two years, and within 10 years, there has not been a single complaint about ghosting on that product. Yes, there can of course be a shaved-off component on the unit - just take a close look and see if there's a mechanical damage.

  • Hi Jens,

    On visual inspection i can't see anything special however i'm noticing that component C31 is missing (at the back of the card). Is this normal?


    regards

  • Dear Jens,


    Please have a look at the images i've sent here to tell me whats happening with my Indi ECS. The Indivision ECS is showing signs of ghosting or shadowing in the picture of both A600 and A500 and on different monitors. It is very evident especially with moving objects on screen. As you can see on the A500 (KSv1.3) there are evident bar vertical lines on the left side of the screen and on the A600 (KS v2.0) you see the ghosting near the Amiga logo. Can you please indicate if this indivision has a failed component/s or its better to send it for repairs?


    Thanks for your help.

    Carlo

  • Hi turrican9,


    It is unacceptable when the RGB out is a far better signal on a 15khz BENQ monitor. So you are telling me that this product is not perfect like the RGB circuitry of 30yrs ago. I don't agree, there is something wrong. I don't remember this product with this hitch when it was purchased. There is something wrong and i'm kindly waiting for Jens's reply. Also Jens mentioned in my previous thread that he had never got a single complaint about ghosting on V1. So it seems that people are experiencing ghosting and dont report it. For example you are experiencing ghosting it seems Turrican9.


    Turrican9 can you please post pictures?

  • Dear Jens, have you seen the pictures i have posted? Turrican9 is experience ghosting on the ECS v1 too. Can you please provide a solution maybe component replacement etc?

  • Indivision ECS V1 has been on the market for almost a decade, and there was not a single complaint about ghosting. These devices are out of production and out of support - sorry, but I won't investigate that.

  • Jens, I don't think this should be the way forward how to treat clients. Seems that there are loads of people that are complaining about ghosting on the V1 and for any apparent reason they opted to shut their mouth instead of showing you that the v1 has problems too.

  • Please try to look at the situation from our perspective. This is a product that was released in 2009 (ten years ago!). Since then, as Jens said, there were zero complaints about a problem with ghosting, and that means we must consider it working right. Development has moved on since then, the product is out of production and superseded by another product. We have to make a clear cut somewhere, because our resources are limited and we simply can not support every product for an unlimited time - especially if the reported problem is something that was never reported for 10 years before. We can not afford to investigate something like this. Also when people experience problems and dont report them - we cant do anything about it. Nor does it change the situation for us - we can only fix what we know about. From my experience that usually does not happen though, most of the time when there are problems, people complain loud and clearly, which again tells us that people didnt have a problem in the first place. This might be different, but again - we can't do anything about it if we do not know about it. And complaining 10 years after the product was released, when its already out of production and superseded by another product, is simply too late, sorry for that.

  • Thanks for your message Tobias. I just wanted to know what could be the problem and fix it myself if needs be (maybe changing components etc). Well i accept your situation. Thanks for your help


    Carlo

  • I just wanted to know what could be the problem and fix it myself if needs be (maybe changing components etc).

    Ghosting generally points to a mismatch of source and target termination. Since the current ghosting reports of Indivision ECS V2 appear to be limited to a small range of monitors, I tend to say "try another monitor", as not all monitors appear to have the required 75-ohms termination in their RGB input lines.

  • The one I got was unbranded but it was a good deal thicker than the standard ones. It also had the ferrite bead on each end. If that fails, you could find a known quality brand like Belkin etc.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.