IndivisionECS v2 Amiga600 not working

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
  • Hi.

    I have installed the IndivisionECS V2 in my a600, using an a604n. I followed the directions on the Wiki page and I am now stuck on a black screen and the tool reporting that the hardware is not found. The installation guide told me to create an resque disk, and test the disk. After creating the disk and trying it, the scandoubler is no longer working. And hooking up an tv to the RGB port and running the configuration tool, reports that it can not find the hardware anymore. Anyone know what the issue is?

  • If the config tool reports "hardware not found", the only thing you need to do is to run the rescue disk. If making that did not work, you can download that from our Wiki.


    What accelerator (if any) is in your A600?

  • Hi Jens.

    I ran both the rescue disk that I made from within the config tool, and I ran the disk that I downloaded from the Wiki page. None of those two disks have brought back the scandoubler. Regarding accelerator, then I have no accelerator installed in my Amiga600. Regarding the a604n module, then I have the version, were not all the pins are populated on the socket. I don't know if this give any clue.

  • Hi Jens....

    I have solved the issue, by installing it in my a500 Rev.5 with kick 1.3 and 512k trapdoor mem that I bought from you. And I ran the rescue disk and had it sitting for 2 minutes after it had started to load the floppy disk. I made shure that it had run through the flashing, by testing "dir" command or was it "list". The IndivisionECS V2 went back into my 600, and it worked again.


    So I am thinking, that it is eighter the Kickstart version, the a604n or perhaps the flashing tool (I am thinking of a bug somewere, that the programmer have been missing for some odd reason) that are the issue, or it might just be my 600 setup combination that are the issue here.


    My mainboard are an Revision 1.5, that has been recapped with ceramic caps. It has the a604n that are not fully populated in the socket, and I am running with kickstart 37.350 and I have an SD-Card solution as the harddisk. It has the KA-Something non-buffered ide adaptor as well.


    Anyway.... Issue solved. 1000 times thank you for the support.

  • Hi Jens! I've got an A600, with KS3.1, a604n, RTC, ECS V2 and AmSider+SD adapter+Furia(from Lotharek). From the icomp parts, only the 1 mb chipram is working. RTC can not bee seen, like there is not at all, also the ECS. The cfg program does not do anything, the flasher says there is no ecs2 chip (1 & 2) I've tried to remove the pin#35 with no any success. Removed all the unnecessry parts( sd fdd furia rtc), but there is nothing. Only chiprams, nothing more. Any suggestion? Maybe there is no probem with ecs, the 604 is the root of my pain... ?

  • Just a few days ago, we've had a support case in combination with a commercially-offered power supply from Poland (see German part of this forum). In the end, Indivision ECS V2 worked fine after we found out that this power supply outputs almost unregulated voltages, and the old 2.5A power supply solved the problem. That was on an A500, but the A600 is even more prone to fail, especially with it's SMD electrolytic capacitors.


    So please get back to me with the info about your PSU. Furia and other parts should not have an influence - these have worked fine with the previous version of Indivision ECS, so I don't expect any trouble.

  • Hi Jens.


    My Amiga600 is running without any Accelerators at all. It was recapped with ceramic tantelum capacitors. The power supply that I am using right now, is the old original Amiga600 supply.



    Upgrades that I have in my 600 at this moment:


    - a604n 1mb ChipRam expansion, the one with socket not fully populated.


    - IndivisionECS V2.


    - KA60 IDE Adaptor.


    - SD-to-IDE adaptor (44pin version)



    Just ordered an A6095 FastRam expansion for my machine and an OS-3.1.4 kit. They will be the last upgrade's that I will be doing to this machine, as I want it to have features, yet retain the compatibility of a stock 600, as much as possible, yet have as many features as possible at the same time.


    EDIT:

    Speaking of PSU. Is an ATX psu with a convertion cable the best choice, when dealing with unregulated PSU's? Sorry if I sound a bit noob. Yet PSU and Amiga are not exactly something that I know a lot about.

  • Is an ATX psu with a convertion cable the best choice, when dealing with unregulated PSU's? Sorry if I sound a bit noob. Yet PSU and Amiga are not exactly something that I know a lot about.

    ATX power supplies mostly have the 12V rail as their main regulation rail. This means that the 5V rail, which is what powers the Amiga, is largely unregulated if there is no considerable load on the 12V rail. As a result, I generally recommend to NOT use ATX power supplies on an Amiga.


    In any case, if you are using the original PSU, it should work and at least let the config/flash tool see the Indivision ECS V2. Just make sure to use the right tool for the right version: The old tool will not see the new V2 and vice versa.


    Just one question:


    It was recapped with ceramic tantelum capacitors.

    So what is it really? Ceramic or tantalums? There is no capacitor technology that combines the two :-)

  • Then I dont know what the seller talked about. It is recapped, and it is not the old elektrolytic caps he used. It is the brownish caps that you might see in my photos. The seller told me they were named ceramic tantalium. And I am not an electronics repairman. So I now I hve no idea what they are.

  • Jens : but with the new tool (IndivisionECSv2-20190128.lha) it's working!!! My 10000 years old LG monitor does not like it at all, but an another small (10usd chinese) LCD works perfecty with it. THX!!!

  • I'm sorry but I still have to read between the lines of your post - since you are making a difference between "flasher" and "config" program, I assume you have been trying the old tools on the hew hardware, which will not work. Please use the latest ECS V2 config/flash tool (both functions in a single program):

    http://wiki.icomp.de/wiki/Indivision_ECS_V2/doc#Download

    Yes. That is the exact tool that I have used. More accurate, the tool found on the rescue version 1.9 disk. And I tried the 1.6 as well. When the ECS V2 is installed in my a604n, then it will result in a bricked device. Yet it can de salvaged and brought back to life in my Amiga 500 Revision 5 version 3 with kickstart 1.3 (the exact board name is according to big book of amiga hardware).

  • Just one question:


    So what is it really? Ceramic or tantalums? There is no capacitor technology that combines the two :-)

    I have done some investigations. It is ceramic SMD capacitors. I think the seller of my board, thought that they were tantalum and ceramic at the same time. I actually learned something new today. :-D

  • OK, so 12 hourts ago, a new support case slipped into this one and solved itself (I mean DnPRuLZ - please confirm).


    Further, brostenen confirms that Indivision ECS V2 works in an A500, but not in the 600, is that correct? If so, the only part that we need to investigate is operation of the rescue disk on an A600. Once again, please confirm - for the time being, I consider this "solved", as you can bring the Indivision ECS V2 back to life with your A500 and put it back into the A600 where it works as long as the rescue disk is not launched.