P96 3.3.3 and crash when opening picture in multiview

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • With a P96 workbench screen, please open attached "DoggieBackground.lace" picture in Multiview and then use Multiview's menu item to open it up in a separate screen. I get the following MuForce hit "doglace.txt" and graphic corruption.

    I'm not 100% certain if coming from P96 but seems like it could be since if I do the same from a workbench screen that is set to a native NTSC screen mode there is no issue.



  • I narrowed it down a bit:

    If Workbench screen is 32 colors, then when picture is loaded on its own screen, then no issue.

    If Workbench screen is 256 , then see the issue. I haven't tried other color modes.

    The best way to reproduce is to make sure a P96 driver is loaded in monitor drivers and boot into a 256 color wb screen and then load picture in multiview and switch full screen mode.

  • Reposting what I posted on EAB here:

    I tried ilbm.datatype 45.3 and picture.datatype 47.19 and this is working. It opens up native Amiga screen and I don't see the crash anymore.

    If I go to the 3.1.4 version of both picture.datatype 46.13 and ilbm.datatype 45.3 then the behavior is different. It uses P96 screen instead of native amiga screen. Also, in this case I did not see crash.

    So something to do with 47.6 ilbm.datatype in 3.2 I suppose or interaction with P96?

  • So something to do with 47.6 ilbm.datatype in 3.2 I suppose or interaction with P96?

    I'd like to re-direct this to the OS3.2 team, as they know best what they have changed. The picture datatype appears to be key: Is this using FPU code? Maybe your setup doesn't have one?