Arrowkey "stuck" in menu mode

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • I am experiencing a small irritating thing with my newly arrived hardware.. I have what looks like a software error, resulting in a “stuck” arrow key in the menu mode..

    I tryed the following without any help:

    Several reboot, soft and hard

    Ensuring shiftlock is not pressed or enabled

    Joystick unplugged

    Check the link to see a small crappy video that shows the problem:

  • weird... could you check if the same happens when pressing the cursor keys on a connected ps/2 keyboard? (still in cartridge mode). If possible, also please try with another C64. I can not reproduce this here (and the respective code has been in use for ages... so probably it works right :))

  • Other sources where this may come from are the PS2 keyboard and Infrared. There's a menu option that lets you disable the IR detector, so if there's some unwanted IR signals in your room, the Chameleon can ignore it.

    I'm sure you would have checked a PS2 keyboard if you had installed one.

  • I would like to test a PS2 keyboard, but unfortunately I don't have any.. :( And my second C64 seems not to be working atm (typically)...

    I'll see if I can manage to get into the menu area where I can disable the IR detector

  • ..IR Receiver is now off (I have to hit the enter key at exact right moment to enter the menu areas).. problem still there...

    .. and now I have screen flickering due to some other settings I managed to change in my quest to enter the input settings menu and disable the IR received.. :)

  • I was thinking of a CIA failure that causes the joystick-down bit to be stuck. The easiest way to find out if the fault comes from the C64 is to try out stand-alone mode, but you'd need the CDTV remote control, a PS2 keyboard or the Docking Station to make that test. So.. does any of your friends who live close by have a PS2 keyboard?

  • hmm... more errors...

    1) I cannot "Reset with cartridge" - that just hangs the system (Retro Replay selected in Slot 1, with slot 1 as default cartridge)

    2) When accessing the file browser and selecting a .prg file on an SD card with a .d64 file on it, the intro music starts playing fine, but only the yellow screen with mounting information is showing.. but I can hear that it is the intro music playing, and when I press space, the main music starts playing (just trying out an old version of antidote that I know by heart)

    ...and now even "Reset to Basic" fails.. as well as all variants of "Clear Memory.." :(

  • urks... are you sure this C64 is working OK?

    it would really help if you tried the chameleon in standalone mode... if that works, the chameleon is not the problem :)

  • I managed to get a hold of a PS/2 keyboard + USB power supply and started testing, and it seems that it's my old breadbox that fucks up things..

    I disasembled my non-working C64 (newer model) and fixed it today, plugged in the Chameleon and tadaaa... works.. :)

    So, I am a happy camper at the moment.. but still puzzled on what is wrong with my breadbox, as it works flawless without the Chameleon.. ?

  • it could be as simple as dirty expansion port. or even a dirty power connector or power switch. or the CIAs are giving up soon. or mmh... it could be so many things :) here i could fix most cases of irritating behaviour by cleaning the ports/connectors and the power switch however. the later is often underestimated - a subtle voltage drop at the switch can cause really subtle problems, like the one you are seeing.

    that said, it could still be something completely different - good to hear it fors for you now :)

  • This might as well be an edge case in accessing the C64. Please list the exact chip designations, including datcodes and whatever else you find in the computer. I am especially interested in:

    - CIAs

    - PLA

    - board revision

    - any expansions installed in the computer

    - possibly a photo of the 74LS139 that generates the select-signals for the IO chips (if it's a board revision with discrete logic)

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.