X-Surf-500 not working Accelerator Card ACA-1232 25 Mhz

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi All,


    I hope I can get some help here regarding this strange problem. Recently I bought a ACE2b Chip RAM and X-Surf-500 from Jens directly. I have the following hardware:

    1. A500 version 6A Amiga that has be recapped this month with 3.2 ROM

    2. Indivision ECS MK I with latest software.

    3. ACE2a 2 Meg Chip RAM.

    4. ACA-500 not PLUS running 8 Gig CF card for AMIGAOS 3.2 and 16 Gig FAT32 CF Card for AUX. ACA-500 has latest firmware.

    5. X-Surf-500.

    6. To run all this gear I have an external 300w ATX power supply with only an Amiga power plug.


    So here is the problem I am having. Without the Accelerator Card ACA-1232 25 Mhz connected to the ACA-500, everything works perfectly. I can get online with the X-Surf-500 to Jens server. Amiga OS 3.2 is working as it should. The 2 meg chip RAM is showing correctly. Access to the AUX and AmigaOS CF cards are fine. Floppy drive works fine. System runs stable and no problems. But when powering down and installing the Accelerator Card ACA-1232 25 Mhz, X-Surf-500 is permanently off line. With the Accelerator Card ACA-1232 25 Mhz fitted the extra 128 Megs shows and there is a nice improvement in AmigaOS speed.


    I have cleaned both the plugs / ends of ACA-500 and Accelerator Card ACA-1232 25 Mhz with isopropyl alcohol a number of times with no effect.


    Any help would appreciated.

  • To run all this gear I have an external 300w ATX power supply with only an Amiga power plug.

    Please fix that before we spend support time on this. Our PSU FAQ clearly explains why ATX power supplies are a bad idea for Amiga computers.


    There's a similar case in the German part of this forum, where the move from OS3.1 to 3.2 has caused the non-working network. Please try using OS3.1 and see if the networking part works with the ACA1232 installed.

  • While I can only support you in removing the ATX PSU from the equation, we may have a simple OS3.2 problem: The MMU is most likely keeping the device driver from accessing the hardware. I believe you'll find that OS3.1 will work just fine, as that does not use the MMU by default.


    We're discussing possible solutions internally.

  • I will do Jens, Just ordered a new Amiga PSU (NOT ATX TYPE) rated at 65 watts and 8 Amps possible on the 5v rail. I will setup 3 volt meters to constantly check voltage of the new power supply. Also have a 4 channel oscilloscope and will monitor the +12, -12 and 5v rails for ripple. I will sort the PSU first before proceeding. I will get back to you once PSU issue is sorted. Thanks

  • rated at 65 watts and 8 Amps possible on the 5v rail.

    At any rating above 4.5A, please make sure that it has cable drop compensation - otherwise it won't be accurate enough for an Amiga. If it's based on a MeanWell chassis, I can already say that it's not suitable. Unfortunately, there are way too many PSUs on the market that have an Amiga connector, but are sold with false advertising. These only work reliably with moderately-upgrades Amigas. And those are rare these days...

  • Hi Jens,


    Sorry for the delay of getting back to you as I have been in hospital. I have built a test heavy duty linear power supply for further Amiga projects with 6Amps on 12v -12v outputs and 8 Amps on the 5 volt output. I have tested my power supply under load and found voltage ripple is very low while monitoring all voltages with an oscilloscope. Results with AmigaOS 3.2 is still the same with no MMU installed.


    I am trying to get the Network Installer app to run in a freshly installed AmigaOS 3.1 4G CF card. I use F1 in ACA-500 to use 3.1 ROM and AmigaOS 3.1 runs ok with 2 meg fast mem showing and 128 meg showing for accelerator card. When I run Network installer from the AUX card or DH1 on a second partion on the CF card , I get " Unable to open your tool 'installer'" Any idea how to get past this to install the drivers etc. I have also tried this with accelerator card disconnected with same results for AmigaOS 3.1 In AmigaOS 3.2 I can use the network installer program with no problems of installation.

  • UPDATE:


    I have installed a fresh version of AmigaOS 3.2.1 on a 16 Gig CF card. I have also burnt Amiga 3.2.1 ROM. After restart where AmigaOS 3.2.1 states it has detected a 030 Accelerator and that there is missing library's etc, I have said no and pressed enter to carry on. I can detect 2 Meg fast memory and 128 meg memory of the accelerator. The best part the 500-x-Surf is now working and I am online for network. Power supply is stable still. Busy making an image of the CF card before installing the files missing for the 030 card etc. I will advise shortly.

  • Yes, we already know that the mmu library is the culprit here. Getting rid of the ATX power supply is probably something good anyway. However, at 8 amps on the 5V rail, you should add cable drop compensation. It's unlikely that you can meet voltage regulation requirements over the whole load range without such a circuit.


    We are working on a new device driver for the ACA500 (non-plus) that will also work with mmu library.

  • Could you please test the attached version by copying it to AmiTCP:Devs/Networks, and report back if it fixes the problem for you? It's for the ACA500 (non-plus) only. It contains a mmu.library workaround.


    Sometimes mmu.library solves problems that you wouldn't have without mmu.library.

    Therefore my general recommendation would be to not install it unless you know why and have a compelling reason to.

  • I can reproduce the problem under both OS3.1 and OS3.2 with ACA500, X-Surf-500, ACA1233n, and MMULibs. The driver fix above should have fixed the issue, but didn't. We might further investigate the issue, but cannot promise a fix as of yet.

    MMULibs are not required in this combination - I'd suggest to not install them, and remove CPU CHECKINSTALL from OS3.2's S:Startup-Sequence.

    • :)
    • :(
    • ;)
    • :P
    • ^^
    • :D
    • ;(
    • X(
    • :*
    • :|
    • 8o
    • =O
    • <X
    • ||
    • :/
    • :S
    • X/
    • 8)
    • ?(
    • :huh:
    • :rolleyes:
    • :love:
    • 8|
    • :cursing:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :whistling:
    • :evil:
    • :saint:
    • <3
    Marks thread as resolved after post creation.