Aca500+ ver.2 Compact Flash support?

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • The CF card controller was not changed in the 2018 version. What the CF card MUST support is the "trueIDE" mode, and that's mandatory for every CF card. So far, there has been no report of failing CF cards except for a Hama 4G card that also fails in a few other products, including my Canon camera.

    Even some CF-SD card converters are reported to work; I have two of them here, one with a single and another with a dual SD-card slot. Both work. However, since software inside these converters is not static, you never know what the vendor has changed since the last run.

    Please double-check:

    - are all pins of the CF card slot straight?

    - is the card formatted with a file system that the Amiga knows?

    Especially on huge flash cards, Windows uses a variant of FAT that the Amiga does not support ("exFAT"). In that case, right-click on the CFAUX_NDOS icon and choose "format...". If you prefer a shell command, that would be:

    1. format drive CFAUX: name Empty quick noicons
  • Thanks, so for real CF cards they should all work as long as they arent faulty... :)

    I have had a 2GB cf card that always worked in the aux slot, while several difrent SD cards in adapter never worked, fat&fat32 in the AUX.

    While at the same time the Boot slot seemed to like any sd card except a 2gb one.

    And a 1GB cf that neither slot seemed to react to, that suddenly in the boot slot showed up on workbench (I had been powercycling to test the diffrent virtual disk options).

    One sd card worked once, and after a powercycle (I didnt touch it) it was CFAUX:NDOS (and later after trying out several other sd card it became rock solid working)

    All while every card (CF or SD) was readable with my PC.

    Well, all cards are old (and of dubious health) so I'll blame them and buy some fresh CF cards.

  • I've only bought two SD->CF adapters, one with a single slot and another with two slots. Both work. I just chose a cheap brand off ebay.

    Please make sure not to insert too-large SD cards, as they will require SDXC commands to be used, which the adapter may not support (compared to SDHC, the new SDXC commands are fairly new).

    Further, if you want to use the card to transfer data from a PC, a very large card will make a Windows machine format the card with ExFAT insteat of FAT32, which the Amiga does not support. You can still format a card with FAT and a larger block size, so the Amiga supports it - there are GUI-based tools and commandline recommendataions (look for "FAT32 formatter").

    So it may not be the adapter, but the card size you're attempting to use.

  • As the thread starter I want to clarify that My problems was due to a PSU that didnt regulate properly.

    Jens has mentioned this in other threads and I recently checked mine and it was at 4.75v connectedto the amiga(+- whatever % my cheap multimeter gets wrong).

    With another amiga 4.5a psu (that was at 4.95v) all my cards work (well the aux port does not like to hotswap the cf adapter) including the 1gb cf card that I had issues with...

    And my external floppy drive suddenly works again...

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.