Indivision ECS V2 Blackscreen

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • After trying out a little bit with the new Indivision ECS V2 and the A500 (everything ok), I stupidly selected the Rescuedisk on the GOTEK and then the message came up because of 7 seconds or so and afterwards (flashing?) The screen stayed black. I tried to start the tool again, unfortunately without success, it starts but after a short time it is finished.


    I'm a little at a loss, does anyone have a tip?

  • The Rescue disk was generated with the tool, or downloaded from the Wiki?


    We did have some trouble with machines that have very low memory. If you can, please re-run the rescue disk with as much memory enabled/switched on as possible.

  • In any case, please do a power cycle (turn the computer off and on) after flashing.

    Which Kickstart version are you using?

    Low memory is a very unlikely cause, as flashing also works with 512k.

  • Downloaded and unpacked to usb stick/gotek in win10, maybe thats the problem? Never had any issues using winrar etc. to do so


    Having just the 512kb ram expansion and unplugged aca500plus, doesn’t help.


    on weekend i will try to put together another machine from my spareparts for a workaround with floppydisk. Thanks for your support!

  • I made a disk on another a500 and no change, its not working... screen says „invalid flash signature“ same with gotek.


    any ideas?

    Not really. I have just made sure (again) that both the rescue disk from the WIKI as well as the one created with the IndivisionECSv2 config tool (version 2.5) do work under Kickstart 1.3 and with just 512k of memory.

    "Invalid flash signature" is indicative of a hardware problem in my opinion. Maybe Jens has another idea.

  • Unplugging the ACA500plus means that there is no fastmem, so I would not do that. Instead, please insert the floppy, attach the ACA500plus and power up. Once you see that the menu has been started (DisMo shows "FE"), press F1 - then the computer boots with all fastmem, and with the floppy inserted, it will boot from that. This should all be possible "blind", so without any display from the computer.


    screen says „invalid flash signature“

    May I ask how you see that? If Indivision ECS V2 is bricked, then you don't have any display at all on an A500.


    If this procedure does not help, we may really be looking at a hardware problem. However, please follow these steps, so we have a setup with fastmem, which improves success probability :-)

  • This looks like there is no config loaded. At least we know that the flash chip is OK, a core can be loaded and the board gets a clock.


    Are all the pins OK, nothing broken off during all these in-and-out sessions?

  • It worked and i never removed the whole thing from the socket, the case was always closed. The only think i plugged in and out was the DF0 & power cable to switch between gotek and floppy outside the case. For testing and copying disks i have another (barely working) amiga 500 and crt.