Original X-Surf hangs during xsurftest

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hello!


    Hope someone can point me in the right direction. I have an original X-Surf card connected to my A4000D. The card is recognized but the test performed by xsurftest always crashes the computer (See attached picture). The same thing happens if I try to start AmiTCP. The computer hangs, no mouse movement at all. A soft reset works but not immediately, it takes a few seconds between Ctrl-A-A and the actual reset.



    I'm using OS 3.9 BB2. The computer has a CyberstormPPC with 060. I'm using Thor's mmu.library and processor libraries if that's relevant.


    My guess is that it is a software problem but I just cannot figure it out. I had it working fine before, but I stored this A4000D for about 2 or 3 years and now that I want to use it again, everything else seems to work, except this.


    Any clue will be much appreciated.


    Thanks!

    - Efrén

  • The test program is an engineering tool only, it should not be started on the WB, and after launching it once, the computer should be reset. I don't even know if it's compatible with an 060 CPU, but before we jump to conclusions, please just try it by booting without startup-sequence and launching the test program from the command line that you get there, not launching any other piece of software.


    The X-Surf should be connected to a network. The program will try to send out a packet and see if an IRQ comes from the chip after that's done.


    A lot is already working OK - the memory test passing is a very good sign.

  • Hello Jens. Thanks for your reply


    It is solved now, the card is working fine and I can connect. Here's what happened:


    I did run xsurftest booting with no startup sequence but the same thing happened. Then after a few more resets the computer stopped booting completely. I feared something else was damaged so I took it apart and started testing with just the CPU board. It worked.


    Then I started adding things one by one until I added the X-Surf in the same slot it was before and again, no boot. I changed the X-Surf to a different slot and it booted again. So I added everything else, leaving that slot empty (maybe it is damaged, maybe it was just bad luck. In any case I don't use it) and all is fine now. All expansions working and internet connection reestablished :)


    Thanks for your help!


    Regards,

    Efrén