CA-PSU won't power up my A1200 but powers up my A500's

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • I just installed an Indi MK3 and plugged in the new CA-PSU to test things out and found that nothing worked.

    I backtracked and pulled out the Indi MK3 and tried again...not even a flicker of excitement. I did wait before cycling power.


    I thought I'd blown my A1200. Tried the second CA-PSU that I bought, still no joy.


    Plugged in my A1200/600 PSU, everything jumped into life....phew, I thought, thank you to the big imaginary friend in the sky.

    I plugged the Indi back in and it too works with the older PSU.


    Where do I start looking Jens? This is a little baffling.

    I've just reshuffled my man cave and haven't set up my scope yet, but I'm guessing the CA-PSU thinks there's a fault and is keeping my A1200 safe.


    LED on the CA-PSU does not appear to even flicker at power on on both CA-PSU's.


    Thanks for any advice


    Mick

  • Just adding additional info.

    I tested voltage on my A600 PSU and 5V rail was down a little at 4.85, marginal to say the least.

    My A500 PSU is pretty solid at 5.1V with everything in, including the ACA1233n that I bought. Just can't use the new PSU's...gaahhh

  • We've had cases before where some monitor-adapter device allowed voltage to feed back into the Amiga. This is of course sensed by the protection circuits inside the CA-PSU, and it won't let you switch on in case something is "wrong". The obvious fix is to get rid of such spec-violating devices.


    Since you're describing an Indivision AGA MK3, you may still have something "older" conencted to the DB23 that just needs to be disconnected. If that's not the solution, please describe everything that is connected - no matter how small.

  • Nothing else connected Jens, just the CA-PSU. With no monitor, no mouse, no external FDD.

    Internally there is a Gotek an iComp clock and a IDE to CF board. Not a single other source of power anywhere.

  • Sounds similar to a case where I still have to investigate what's wrong with a German customer (he sent in his machine). I will put that on higher prio and get back to you before the end of the week.

  • Yes, the case with the A1200 that was pending is solved, but it was not a "does not power up" case, but a "crashes frequently"-case, which was a mechanical problem: The CA-PSU got damaged in transport.


    So for this one, we really need to start at the very beginning: The 230V plug. If you connect that to the wall, does the green LED on the power brick light up?


    Further, the 5-pin square DIN connector must be pushed all the way into the A1200. Some connectors are a bit stiff (which is good!), but you may not be making 100% contact.

  • Hi Jens,


    Yes the brick lights up and the DIN plug was pushed all way.

    For the record, I have powered on the CA-PSU and get a green light and hot plugged it in, as soon as I do this the LED on the CA-PSU goes out.


    When I say green LED, I mean the one on the CA-PSU, not the brick. The brick LED stays lit all the time.

  • Attached two shots of the inside. While testing, only the PSU is attached. The gotek power and floppy cable are disconnected and all the little black and red wires coming out of the gotek are disconnect from the rotary encoder and LCD that form part of the gotek on the lid of the A1200.


    This identical setup works when the old 4.3A A500 brick is plugged in.

  • What I am more interested in is the cables that are connected to the machine. There must be power going "the wrong way", otherwise the CA-PSU would not be holding off the launch.

  • Not a single other plug connected Jens. Just the power DIN plug, no mouse, joystick, parallel, serial, monitor, audio, floppy, composite, or vga or the other un-named hd video socket

  • Australia and I would imagine quite a bit to send them over, I think I paid over 100 euro to get my last shipment from you, it would cost at least that and more I think.

  • Australia and I would imagine quite a bit to send them over, I think I paid over 100 euro to get my last shipment from you, it would cost at least that and more I think.

    Looked it up - you've paid 35,20 EUR for shipping the two CA-PSUs to your place. If both are behaving exactly the same way, it's hard to believe that there's a defect, as it would have to be the exact same defect on both.

  • I agree that I don't think they are defective. They work with my A500's. But my otherwise perfectly working A1200 doesn't even attempt to start with a CA-PSU driving it, where I have 3 other old shitty Commodore PSU's that do.

    I don't know what to say Jens...I get it that its hard to support someone from the other side of the world and there are so many different variations of the Amiga hardware that I guess its hard to know them all. I really wanted to have a solid power solution for the A1200 that I have just decked out with your top of the range accelerator and flicker fixer, but I feel like I'm stuck with an A500 brick. I guess I can recap that on the weekend and feel a little safer.

    I do feel disappointed though.