Will A3000 boot from Buddha?

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • In the documentation it says:


    Autoboot with Kickstart V1.3, 2.0 and 3.1


    However, I have an old Amiga 3000 that loads its kickstart from disk. I believe it uses a weird 1.4 beta ROM version for bootstrapping. On such a system, will the bootstrap ROM do AutoConfig properly so it can see the Buddha and boot from the DOM or another attached drive?


    This is important to me as I have a 25-year-old SCSI drive that I had to fix this week and will no doubt fail completely in the future, and at that point I want to have a solid state solution to boot the A3000.


    (I had no success connecting several different CF cards to my X-Surf using two IDE-to-CF adapters, by the way. HDToolbox discovers nothing on 2nd.scsi.device. But it makes sense for the original X-Surf to never have been tested with CF cards before it wend EOL, unlike the Buddha.)

  • On such a system, will the bootstrap ROM do AutoConfig properly so it can see the Buddha and boot from the DOM or another attached drive?

    Yes, it does. I remember having only a Buddha controller for many years in a 16MHz-Kickstart-booting A3000. This was with the old Elaborate Bytes ROM that still works with the latest controller, using the device name "scsi.device". However, I expect the same to be true for the new drivers that use the device name "buddhascsi.device". Key to loading the Kickstart file (with A3000 bonus code) fromt he DEVS: directory is the right partition name (not the file system name).


    We currently have an open support case in the German part of this forum where someone is attempting to set this up. Unfortunately, I can't try it here, as the A3000 in question has ceased operation - and I don't have any time to fix it (for years..).

  • Hm, my German isn't so great but it looks like he's trying to boot a 3.1 superkickstart.


    I actually boot from the original 2.0 superkickstart and then soft-kick a 3.0 kickstart, which is of course not the most efficient way to operate. I've been thinking about making a wb_1.3: partition and then put a 3.x superkickstart there, keeping the 2.0 one in wb_2.x:. For some time now I've barely used the A3000 as the fan noise was so loud, but I replaced the fan yesterday so I expect to use the 3000 more from now on.


    I've sent in my order for the Buddha and did the bank transfer.

  • Hi together I'm the one with the open German support case. I have also an Amiga 3000 25 Mhz with Superkickstart Boot Rom and no "real" kickstart on the mainboard and just bought an Buddha IDE card.

    After successfull hardware installation of the Buddha and connecting to a CF card adapter at first is was not possible to start the Installation program on the DOM - there was presentation error of the tool-UI in combination with my Cybervisin 64 card or Kick3.1 on my SCSI drive - however I started with my kickstart-disk and my orginal WB 2.0 SCSI Installation disk in PAL-HIRES and then I was able to start the Installation program from the DOM and sucessfully partioned, formatted and installed WB3.1 on my CF Card.

    After reset and boot from my SCSI drive the new partions where shown with all AOS content and about double speed against may Quantum LS52


    But I was not able to fully boot up my Amiga with the newly configured IDE Drives. Based on internet search I found this story with a similar but even worse problem: https://amigax1000.blogspot.co…-part-1.html#comment-form


    Based on the latest hint of Jens, I just was able to add the attribute "buddhascsi.device" instead of the "scsi.device" to the HDToolbox-icon attributes. With this, HDToolbox showed the IDE Devices and I was able to re-partition the standard-partitioning which was done on my 8GB CF Card. The first partiton was automatically set to 512MB which should be supported size. But the standard procedure uses not a Amiga-DOS/FFS format, but an "PFS3"-Format. Additionally the partion-name is "BDH0" instead of "WB_2.x" as it is needed for the Kickrom-load and it was not flagged as bootable. Also I found, that the "Start Cyl" starts with 2, where at my original SCSI-Drive the "Start Cyl" starts with 4.


    So at first I backuped the whole BD0: Amiga OS 3.1 Installation to the Work: partion on the CF Card. Then I changed the BD0 partion to match all requirements for a Kick-Rom partion as decibed above - all data on BD0 was deleted as expected.


    Next step: Format the new WB_2.x without international mode as described in the blog above.

    Then: Copy the backup of the AOS installation again to the newly formatted partion

    Then: Copy the original 3000 Kickstart from the SCSI: WB_2.x Partion/Devs to CF:WB_2.x/Devs

    - eventually you must name the CF Card not WB_2.x, but just WB_2 for thsi copy step with connected SCSI and CF and after the copy disconnect the SCSI, Boot from floppy and rename the partition on CF to WB_2.x within HDToolbox.

    In principle, I assumed, this should work for booting from IDE on a superkickstart A3000 - but unfortunately It did no work fully.


    After power-off and disconnecting the SCSI drive and again power-on the A3000 just showed the kickstart-load dialog where you can select to load a kickstart from HD or Floppy, but the HD-Icon was grayed out. :-(

    So I re-connected the SCSI boot drive and tried again. Then, as to be expected, the Kickstart was again load from the HD, and it boots also from HD. :-(

    Next try: Just reset, without power-off, then hold both mouse buttons to show boot-selection screen of A3000. (have in mind: in this case the kickstart from the SCSI boot is still im RAM)

    Then, the CF-Card "WB_2.x" is shown as "WB_2.y" in the boot menue - our Amiga is not silly and just counted up in case of a nem conflict :-)

    So select the WB_2.y and then boot from it.


    YES: it boots up the Workbench from the CF Card :-) BUT only, if the kickstart is already in the memory!


    In the Blog above, it was mentioned to use the orginal Installation disk to get special parts on the boot-drive.

    Again I formated the CF-Card WB_2.x partion on the CF card and then boot again by Kickstart disk without SCSI-H but with orginal WB2.04 HD installation floppy and installed WB2 by installer on the CF partition. It asked also if this is an superkickstart Amiga and for the Superkickstart floppy to be copied to the CF partion.

    After finish of the installer I booted again and hope, that this time the CF partion is recognized and bootable - but i wasn't. I was the same as with the manual copy after reformatting the WB_2.x CF partion and manual copy AOS and kickstart to this partition.


    So the current status is, that is is not possible to load the Kickstart from an IDE drive from the superkickstart-rom. But once the Kickstart was loaded in the RAM, it is possible to boot by the bootloader the WB from the CF card by holding down both mouse buttons after a reset.


    So I'm wondering if there may be really a direct-boot solution for a superkickstart-ROM A 3000 based on IDE drives? Because the boot works fine once the kickstart was load into the RAM and the good performance of my CF card shows, that Buddha is a really good approach. For me in the exchange of the superkickstart-ROMS against a kick 3.1 on my mainboard still an option, if no better Ideas pops up here.


    But til then:

    - Eventually there is something in the 4 cylinders in the beginning of the SCSI HD which is needed by the Superkickstart Bootloader? But there is no "custom Boot Code flag" also for the original SCSI drive visible.

    can whatever be brought from SCSI to the CF Card?

    - exists eventually a HD copy program for Amiga where I can copy the 14MB SCSI partition to the 512MB CF partion by tracks not by files - I have somthing like this in mind - but I forgot the name of the tool.


    Here are some Screenshots with details of the Wb_2.x Partition and BootOptin Menue as it is now after all this steps.

    Name is here just WB_2 - later renamed to WB_2.x:


    Here the Bootmenu after I renamed the CF Partition to WB_3.x - the WB_2.x is the SCSI drive

  • To my knowledge, the device name must be WB_2.x:, so no matter what boot device you choose, it will always look for the Kickstart file on the WB2.x: partition in the DEVS: directory. Your attempt of keeping a different Kickstart on a different partition cannot work - it'll always load the Kickstart from the WB2.x: partition. So you'll have to live with booting 3.1 from a partition with a different name :-)

  • My understanding is that you can either load the superkickstart from a partition named wb_2.x or a partition named wb_1.3


    Not sure if the system checks whether the kickstart on wb_2.x is actually version 2.x and on wb_1.3 is actually 1.3. So one option would be to make a kickstart 3.x superkickstart file and put in on a wb_1.3 partition and then see if you get the choice between 2.x and 1.3 in the boot screen with the two mouse buttons.


    Also see MakeSuperDisk.


    I'm considering changing the partition on the DOM to allow loading the superkickstart so I can exchange CF cards (when the computer is off) without impacting how the computer boots.


    I don't really remember how I transferred the data from my 1.8 GB HDD to a 4 GB CF card on my Amiga 1200, that was in 2012, I think. But the result was an exact copy with all the partitions and even the drive geometry in HDToolbox still looks like the HDD, with only 1.8 GB available. A tool like Unix dd should be able to do this, see dd.lzh.

  • To my knowledge, the device name must be WB_2.x:, so no matter what boot device you choose, it will always look for the Kickstart file on the WB2.x: partition in the DEVS: directory.

    Yes, absolutely agree! That is what I tested first: I named the new CF-Card partition in the HDToolbox as "WB_2.x" also the Name of the HD on operating system level was "WB_2.x" - details above in the log text.


    Quote

    Your attempt of keeping a different Kickstart on a different partition cannot work - it'll always load the Kickstart from the WB2.x: partition. So you'll have to live with booting 3.1 from a partition with a different name :-)

    at first I disconnected my SCSI drive with the same WB_2.x device name and tried to boot the kickstart from the CF partion. But this did not work either.

    So after all fails I re-named the CF partition from WB_2.x to WB_3.x to can differentiate better in the boot-menue. Thats the picture from. I just wanted to show, that both partitions have the AOS/FFS and are bootable - works just after loading kickstart from SCSI.

    On both partitions is Kickstart 40.70 as kickstart file in the DEVS-folder.

  • I thought further about reasons and solutions.

    I checked now the versions of the AOS/FFS on the original SCSI hard hisk

    And the AOS/FFS version on the CF card:


    As you can see, the FFS version on the CF card is 44.6 where the FFS on the original SCSI drive is 36.104.


    The reason may be, that I used HDToolbox from my current Workbench installation to to set-up the CF partitions, not the HDToolbox from thr orginal Workbench installation floppy.


    Eventually this new Fast File System Version prevents the ancient super-kickstart bootstrap ROM from finding the Kickstart on the CF Card??


    So next step is, to install the orginal WB 2.04 FFS version onto the CF partition, rename the CF partition again to WB_2.x, remove the SCSI drive again and give it another try. But not this night anymore...

  • So, I just tested the approach from my last post:

    1. copied the FastFileSystem from the L: of the original WB 2.04 Disk to CF-Card L:FastFileSystem2.04

    2. Opened HDToolbox and there under advanved options deleted the FastFileSystem version 44.6 and the added the FastFileSystem2.04 = 36.104

    3. Renamed the CF partition to WB_2.x

    4. Switch off/on

    5. Boot/Load Kickstart from SCSI and checked, that the CF Partition is still OK and bootable by Boot-Options screen -> the downgrade of the FFS from 44.6 to 36.104 did not delete anything

    6. switch off and disconnect the SCSI drive (now only the Buddha CF card with the WB_2.x is connected

    7. switch on again


    Result is, that it does not work!:( :cursing:


    The Boostrap ROM Kickstart Menue only shows the dialog to load a kickstart, but does not offer an Hard-Drive option, just Floppy als seen on the screen 2 post earlier.


    So I have no glue anymore what else we may test. My assumption is, that the Bootstrap ROM only recognizes real SCSI Hard Drives to load the superkickstart.

    The only option may be, that something in the blocks before the first partition of the HD/CFCard can be stored to support the Bootstrap ROM of the A3000

  • Please try flashing the old firmware from Elaborate Bytes - that uses the device name "scsi.device", and it's the firmware I used to use back when My A3000 was still working.


    Remember to lift the write-protection of the Buddha on power-up (see Wiki).

  • O.K. I can give it another try. Just to be sure, that I will do the right things:


    1. I use this wiki page as instruction: http://wiki.icomp.de/wiki/Buddha_flashing

    2. I will use the procedure for "20-year anniversary edition"

    3. The tool BFlashTool will not need to change any jumpers to realease for flashing - just hold left mouse button during power-on


    But I'm not sure where to find the elaborate firmware your are referencing to - Google gives no real hits for this. Or do I find this in the download section for Buddha? Which one? http://wiki.icomp.de/wiki/Buddha#Download

  • This morning my Buddha arrived. Short version: it won't boot my superkickstart A3000. Longer version:


    I first used the tools on the Buddha DOM to install 3.1 on a CF card. That (of course) didn't let me boot my A3000 from the CF card.


    I disconnected the SCSI drive and used the Amiga 3000 WB 2.0 installer to install the system on a 128 MB CF card. That didn't work at first because the disk setup tools assume scsi.device. So I set up a wb2.x: (and a Work) partition manually. (When you set a tooltype scsci_device_name=buddhascsi.device the HDToolbox will let you do this. Or start it from the CLI/Shell with the device name as the argument.)


    The installer then did its thing no problem, but when rebooting, I got the kickstart selection screen with the HDD options unavailable. After loading kickstart from disk, I got the "insert workbench disk" screen. After loading WB 2.0, the volumes on the CF card didn't show up. So I assumed the A3000 boot ROMs as well as the 2.0 kickstart won't work with the Buddha.


    However, it turned out my CF card had two "custom" file systems on it. The first was probably version 44.6 of FFS, the second version 10.5 or 18.5 (sorry, my A3000's video is not very good... fortunately I have a CyberVision 64/3D) of some other file system. After removing those, WB 2.0 would recognize the partitions on the CF card.


    Also, as I've mentioned before, I have a rather weird setup where the A3000 loads the kickstart 2.0 from the HDD as a superkickstart, but then it loads the 3.0 kickstart. The kickstart 3.0 has no issue recognizing the partitions on the CF card.


    Then of course I applied Jens' suggestion to downgrade the Buddha firmware to a previous version that still uses the scsi.device name, but then the CF cards weren't recognized at all. So I reflashed to the latest version again.


    Conclusion: if I want this A3000 to boot from a CF card connected to the Buddha, I'll have to install kickstart 3.0 (or higher) ROMs.


    For now I'll just use the SCSI drive to load kickstart 3.0 and then boot from the CF card. But at some point I think I'll install new ROMs. (I need to find someone to do maintenance on my A3000's motherboard anyway, as it still has the original clock battery and the flickerfixer adjustment screw seems to be broken.) But right now the SCSI drive still works and after booting, I'll put it to sleep so it doesn't bother me with its noise.

  • I seems, that Iljitsch and I worked in parallel. Yesterday I also downgraded my Buddah as suggested by Jens. I experienced also, that most CF cards (1GB-8GB) which ran well before the downgrade, were not recognized anymore after the downgrade.

    But the whole time the Installation DOM was recognized as drive - but not the also inserted CF card.

    Also the Boot menue and HDToolbox directly recognized the Buddha as 2nd scsi controller:


    Booting from BUDDHA_INST worked with the downgrated firmware, but also the installation program on the DOM did not recognized the CF card.


    I tried all my CF cards, which I used before the downgrade - only this one, which was installed by the Buddha Installer with WB2.0 and default partitioning before the downgrade worked as before:


    This ones with the same capacity and and also formated with the orginal buddhaScsi firmware did not work with the old eb firmware:

  • Oh, one more thing: it seems sometimes partitions on the CF card are recognized as existing, but not as bootable. I don't remember exactly when this happened, though.


    I mostly tried with a 128 MB card and an 8 GB one (with only partitions on the first 4 GB).

  • I ordered and just installed the Kickstart 3.x Rom from Cloanto instead my 1.5 Bootstrap ROMs in my A3000.

    Now the Buddha with latest buddhascsi.device boots perfectly from any CF card quickly and have support for larger disks that 4 GB. From my side I don't need a modified ed firmware anymore.


    Edit by admin:

    CAUTION: iComp does not recommend Cloanto products. If you have a Cloanto Kickstart in your computer, we can no longer provide support.

  • Ah, that sounds good. I'll do the same at some point, maybe when AmigaOS 3.2 comes out.


    The A3000 has four ROM slots, where were the original ROMs and where did you put the new ones?


    I also wonder if kickstart in ROM is slower than in RAM. For my A1260 accelerator card in my 1200 that is definitely the case so the card copies the ROMs to RAM upon boot by default.

  • The Cloanto Kickstarts - apart from not being recommended by iComp - are not required. Emulation shows that the original loader does boot from the Buddha, no matter what ROM version is used on the Buddha itself. It just boots Kickstart from WB_2.x:DEVS/kickstart and does not show the selection screen.


    I recommend to look for the cause instead of spending money for something you don't really need.