Problems finding the VIC-II chip

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi

    Two years ago I bought this MK2 board but did not get it working. I tried to have my PC find the board with no luck. Admitted I am not very good at the software part, so I put aside the board for a period. Then I met a person who had one too and he told me how to upgrade the software. This done I put some chips in but it was not working. I thought the chips were not working and tried to find some on eBay. Finally I got some chips but still no luck. Then yeasterday I met a third Commodore 64 fan who had several working boards. We used three different working VIC-II chips but all gave the same error: Error: VIC-II is not recognized, check U19.

    I have tried cleaning the socket. I have tried measuring the connection from the chip to the bottom of the board (no problem here) and I have tried with other SID chips and CPU chips. And finally I have tried to use the former software and the the newest version. All with no luck.

  • So am I right that you were successful accessing the remote control menu now? If so, please post the chipset information with all numbers that it shows. This may give us a hint about what's wrong.


    Please also mention the power supply that you're using, as the stability of the 12V input affects reliability of the chip recognition part.

  • Well, now it seems it can read it after being turned off for a couple of days:

    ------------------------------------------------------------

    A - Audio output

    B - IEC burst option

    D - Remote debugging

    F - Factory tests

    I - Chipset info

    K - Configure Keys (RESTORE and RESET/POWER)

    L - Load default settings

    M - Memory and ROM selection

    R - Reset machine

    S - Stereo SID options

    T - TOD clock frequency

    U - Upload ROMs

    W - Write settings

    Z - Reinitialize memory and reload ROM images from flash


    ?

    VIC-II: 6569 (1D 5F AF55 PAL)

    SID 1 : 6581 (9F CF)

    SID 2 : 6581 (9E CB)

    CPU : PHI2 OK (0455)

    MCU : 20180227

    READY (press key for menu)

  • By the way: I have only one PSU and it is brand new. It says:

    AC ADAPTER

    MODEL: TDX-1201500

    INPUT: 100-240V - 50/60hZ 0.6A

    OUTPUT: 12V 1.5A

  • OK - that means the detection actually work.


    Now, we need to find out why you get a black screen - how are you connecting the MK2 to your monitor, and what kind of monitor are you using?

  • I have tried both the video output and the S-VHS output and both are connected to the S-VHS input on a rather old LCD television.

    The television has a perfect picture with other Commodore 64.

  • First thing I'd try is moving the chips sideways in the sockets while they are closed (lever down). This will scratch the contacts a little and solve contact problems due to oxidized pins.


    Some people even swap the lever position, which may also cause a black screen.


    Last not least, the CIA chips may be bad - try swapping them for each other. Further, please try without any external hardware connected.

  • I tried moving the chips as proposed but no effect. Also tried swapping the CIA chips with no luck. No external hardware has been connected during my tests.

  • With broken CIAs you'd still get at least "some" picture though... Actually you can remove the CIAs and the SIDs for testing, you should get atleast the BASIC powerup screen (without blinking cursor).


    That said, do you really get "no picture" or do you get a "picture", but its all black? (wenn you power off and on again, does the monitor do "something"?). "all black" picture usually indicates either broken CPU or Kernal ROM. Thats another thing you can check actually, use "M" in the remote menu and make sure you have the default kernal rom active.

  • The screen goes from black to really black, which indicates that there is actually some kind of video signal.

    Both Kernal and Character ROM is set to default

  • Do you have a possibility to test the CPU? The mere fact that it outputs a Phi2 signal does not mean that it's working. Without the CPU to initialize the chips around it, the picture will stay black.

    • :)
    • :(
    • ;)
    • :P
    • ^^
    • :D
    • ;(
    • X(
    • :*
    • :|
    • 8o
    • =O
    • <X
    • ||
    • :/
    • :S
    • X/
    • 8)
    • ?(
    • :huh:
    • :rolleyes:
    • :love:
    • 8|
    • :cursing:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :whistling:
    • :evil:
    • :saint:
    • <3
    Marks thread as resolved after post creation.