Power and grounding for the RapidRoad

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hello!


    I'm planning on ordering a RapidRoad USB soon to use on my ACA500Plus and I have couple of questions.


    1) Does the rapidroad need to be grounded if used on an ACA500Plus? If it is needed, then would one of the mounting holes in the ACA500Plus be used? Easiest being the one in upper right corner in this picture:


    https://icomp.de/shop-icomp/as…e_production-5a115a8b.jpg


    2) Is power via the floppy molex needed for the RapidRoad? If power cannot be provided that way can an external powered USB hub be used?

    I currently have ACA1221lc attached to the ACA500Plus and according to one of the pictures of ACA1221ec in your shop the molex power can be used from there:


    https://icomp.de/shop-icomp/as…1221_rtc_usb-01b07f17.jpg


    Now I've already ordered a used ACA1232 and going to swap my ACA1221lc to that, but then I lose the floppy power connector. Do I need to find a floppy molex power somewhere, use a powered hub, or am I screwed? :P


    BR,

    Rontti

  • Grounding is alwas good; all mounting holes of the ACA500plus are grounded, so choose any hole you like.


    As for power, ther's no really good solution for an A500. RapidRoad was designed for the A1200 and it's accelerators, but when I designed the ACA500plus, I wouldn't have thought that people want to max it out this way. In short: It'll have to be a "tinkering solution", as RapidRoad requires the 5V supply from the Amiga, not from a USB hub. Also, you should think twice about what USB devices you want to connect, as all of that power needs to come from the A500 power supply. It should not only be able to provide that kind of power, but it should also be able to compensate for the additional losses in the cable and the Amiga's input filter.

  • Hello Jens,


    And thank you for the quick reply!


    I figured grounding is a good idea and that part of my "problem" is easy to fix.


    What comes to power I figured that's the answer, but never hurts to ask. I am a little bit of a tinkerer, so I'll think of something conserning this. I am using an old modified 200W AT power supply which has free molex connectors so I'll just keep using that.


    Thanks and you can mark this as resolved. :)


    -Rontti