Trouble with red screen attempting Maprom on ACA1233n

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Machine - A1200

    Card - ACA1233n-40

    Internal ROM - 3.0

    Workbench - 3.1

    ACATool - 2.1

    Good evening, I wonder if I could get some Easter accelerator help - I just bought a second hand ACA1233n-40 and I love the card it's fantastic.

    Having also just purchased Hyperion's Amiga OS 3.1.4, I wanted to get it installed and assumed that it would be best to first have maprom load up 3.1.4 rom from memory on the ACA1233n-40 ?

    Having initially looked for tutorials on youtube and web, I started playing with ACATune, ACAMaprom etc, before realising that the newer ACATool should be used instead.

    So I tried the following:

    - placed ACATool to my C on Amiga 1200

    - placed Hyperion's 'kick.a1200.46.143' (524,288 bytes) into sys:Kickstarts/

    - Run the GUI and first just tested if I can maprom the existing 3.0 internal ROM to fast memory

    check on command line:

    - hard reboot Amiga and all seems fine

    - then jump back to GUI and attempt to set ROM file location to Workbench:Kickstarts/kick.a1200.46.143

    - Hard reboot and I simply get red screen

    - navigate back to Workbench by left mouse button to remove maprom

    - attempt to place kick in various other locations like C: S: or DEVS/Kickstarts but get the same red screen on hard reboot

    I might be missing something obvious, as I'm completely new to Amiga config, but any help would be appreciated?

    Another option I was considering was just installing 3.1.4 without doing the maprom, and set the maprom up when 3.1.4 is finished but I didn't know if that would work and/or upset the install. Either way I'd like to figure out why I'm currently getting red screens?

  • Trying to investigate further I was advised on a friendly discord group to carry out checksum on rom file at both ends.

    So checksum on source rom file unzipped from Hyperion website:


    Then after I've packed file into an adf and transfered to Amiga via either ADF Opus or Winuae and then USB stick to Gotek - I get the following checksum on the Amiga 1200:


    Tried grabbing a fresh copy and get the same result.

    I assume this might have something to do with my issue? I guess I should test a completely different rom perhaps

  • That wrong checksum indeed is the cause: Red screen means "ROM checksum not OK". One of the transfer methods trashes your target data.

    This reminds me of the Catweasel development back in 1997: We were looking for a driver problem for almost a week because target data was trashed upon copying. We then found that the "copy" command from OS3.0 is the culprit. Please replace that with the copy command of OS3.1 or higher.

  • Thanks for confirming.

    So my underlying 3.0 physical roms are to blame even though I'm running OS3.1 on top?

    By 'replace' are you meaning just get physical 3.1 roms, otherwise how would I change the behaviour of OS3.1's 'copy' command?

    As a side note is there any way to make a kickstart floppy that holds a tweaked startup sequence feeding the ACA1233n the ACAtool command to push a rom file on the floppy to accelerator's memory? as someone in a tutorial I was following used ACAMapROM to do that. But I assume ACAMapROM is now not supported?

  • So my underlying 3.0 physical roms are to blame even though I'm running OS3.1 on top?

    No, it may just be the "copy" command, which is in your C: directory. And this applies to both your real computer and your emulated machine.

    You can of course make a floppy using ACAtool, but why would you want to do that if you're booting form a much faster medium? You should make sure to solve the transfer problem before you get to another problem. Step-by-step is a proven concept.

  • Fair point Jens.

    So after a tip from discord group I ended up just unpacking a zipped version of the rom from adf on my Amiga using:

    1. unzip -d dh0:Kickstarts/

    This got around the 'copy' issue. and I was able to install 3.1.4 in the end.