Dodgy Amiga 1200 hardware

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Greetings everyone,

    This may be somewhat off-topic, but I figured I'd ask anyway.

    I have an Amiga 1200 by Escom (from Amiga Magic German bundle, board revision 1D).

    I have this disturbing hardware problem with the Amiga randomly GURUing and sometimes rebooting. This happens with no additional hardware installed, just the HDD.

    Tried a couple different PSUs to no avail.

    The problem can be almost certainly reproduced by soft-resetting the Amiga and getting to the configuration screen (with boot order and stuff) - and in the menus there, instead of names of boot devices - garbage appears, as if there's some memory corruption happening.

    I know, that sounds very much like bad capacitors, but when I've de-soldered all the electrolytic ones, their capacitance measures within the margin of error from their stated value. Could they have still gone bad? I've already ordered a replacement kit, will see if it solves it.

    What could be other causes for that? Bad RAM(is there a reliable way to test chip ram?), CPU cache, custom chips? Will my newly-ordered ACA1233n help me with that somehow?

  • Have you checked that all the chips, if socketed, are all firmly in place? Have you tried SysInfo to look at the system? Perhaps you have a flaky custom chip....the accelerator won't help video output...

  • Take a pic of the "garbage" - that should give us a lot more info than any description you can think of. I have an idea or two, but would like to confirm with what you see in case of a crash.

  • Have you checked that all the chips, if socketed, are all firmly in place? Have you tried SysInfo to look at the system? Perhaps you have a flaky custom chip....the accelerator won't help video output...

    All custom chips on the A1200 are soldered. No, haven't tried SysInfo yet, as I didn't have any options of transferring files to Amiga from PC at the time. Now I do, but have to wait for the caps..

  • Sad news - recapping did not help :( But now I know, that the problem appears when the Amiga has been working for some time and heated up. The longer it's up - the worse. Starts from random software errors, then at some point begins cyclically rebooting after GURUs (random errors like 8000 0004, 8000 000C). And garbage in the early startup screen. Should I replace Chip RAM, maybe?

    some screen pics:

  • if its heat related it could be a poor joint on "something" "somewhere" on the board, id start re-flowing Alice first as she gets the hottest on a general run and test and just continue chip by chip up the board.

  • Well, after reflowing the chips, I'm getting the green screen. I guess I'd start with replacing the chip ram, and then Alice, if it doesn't help.

    Chip ram is a good place to start with replacements, further research shows its a strong chance ram could be the culprit. Wishing you the best of luck!

  • If the computer started before, but gives you a green screen after re-soldering the chips, then the soldering was bad. Look for shorts that you have most likely made while re-soldering Alice.

    The Guru messages show that the computer crashes in fast ram area, so I'd first remove anything that's installed in the trapdoor. There's probably a fast ram expansion that suffers from a leaked RTC battery.

  • I fixed it. It turned out that I missed a solder bridge on address line 4 on one of the DRAM chips, now everything works a treat, including the ACA1233n that I got just yesterday, woohoo! So yeah, the reflow fixed the original problem, wherever it was, I just accidentally put a solder bridge between A4 and ground, found it while doing a continuity test of chip ram lanes.

  • If locations and read/write patters are not repeatable, you may have a power supply ripple problem. Do you happen to have a spare A500/A600 or A1200 power supply?

  • seems like it's Alice issue after all. When I tried to run tests again, I suddenly started getting gurus when inserting a PCMCIA card, and now it doesn't even boot - no video signal with onboard CPU, black screen when the ACA1233n is inserted.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.