X-Surf 100 and Rapid Road not working after AmigaOS 3.1.4 upgrade

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • USB and networking stopped working after installing AmigaOS 3.1.4 and mmulib on my Amiga 4000/040.

    xsurftest now returns the following:

    1. Board address = 0x40000000
    2. nic=40000c00
    3. Searching for RTL8019 at 0x300...not found! (ID0=255, ID1=255)
    4. Testing 16bit memory...Test pattern result points to a cache problem. Please use "-nocache" or "-freezecache" option.

    Running the same command with -nocache worked.

    MuTool returns:

    Memory at address 0x40000000 doesn't show the CacheInhibit flag.

    If I run the following command:

    1. MuSetCacheMode from 0x40000000 size 0x00010000 cacheinhibit io

    Both X-Surf 100 and RapingRoad start working again.

    Any idea why? Why cache is no longer set correctly after a reboot?



  • Something else I just noticed: cache is correctly disabled if I skip the "loadmodule romupdate" in the startup-sequence. It means that the issue is only with kickstart 3.1.4. With original kickstart 3.1, cache is correctly handled.

  • As you have already pointed out, this is an issue of 3.1.4, which should be reported to the vendor of that. Caches MUST NOT be enabled on anything else but memory, and the Z3 autoconfig clearly does not add the space to the freemem list.

    Are you a betatester, or did sales of 3.1.4 already start?

  • Did you try the new mmu library by Thor?

    ah thanks I didn't realize Thor just released a new version on aminet. Anyhow just tried and same thing...lights on and RR sees it ok as unit 0 but it juts won't initialize?? Is there a newer version of Poseidon?

  • Poseidon has not been updated - and it's not required, as other users are confirming. This is clearly an issue with OS3.1.4, so you should turn to Hyperion for support. We have only advertised the X-Surf-100 and RapidRoad as compatible with OS3.1.

  • ok so great news is that my RapidRoad is again working BUT not with my XSurf100....it's now happily working on the clockport of my Buddha Flash so the problem wasn't the OS3.14 upgrade after all!

    I'm ok with this since my XSurf100 is working fine getting me online so most likely something wrong with the RapidRoad interface..regardless very happy my Buddha 20th anniversary edition came with a built in clockport :-)

  • I have the X-Surf-100 and rapid road working on two Amigas with AmigaOS 3.1.4. Amiga 4000 with a 060 and an Amiga 2000 with a 030. Both have the 3.1.4 Kickstart EPROMs and I use Thor's MMU library and CPU libraries.

  • I've got the networking going but the Rapid Road dies at boot from an enumeration error that Trident blames on the USB driver. I've installed MMU library but I didn't see a CPU library on Aminet...do you have a filename?

  • Thanks...the problem was with the drivers in the Poseidon install. I went to the alternative drivers that are in the download area and RapidRoad fired up for the first time....problem solved!

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.