"IndivisionECSv2 hardware not found." but working and installed in A500 w/Vampire500 V2+ and 3.1.4 ROM

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • In the spirit of continuing to take my A500 to the maximum I requested an Indivision ECS v2 for Christmas from my wife. It arrived and this morning I got it installed and quickly confirmed the VGA output was working on my Dell U2410f monitor. I am really excited to FINALLY have such a device for my 500!

    I downloaded the IndivisionECSv2 configuration tool to try to adjust the settings to get things a bit closer to the aspect ratio of display on my CRT. (The Dell has pitiful options for display adjustment beyond color options.) I believe the tool is the latest version at 1.6. When launched it displays "IndivisionECSv2 hardware not found. Continue?" The hardware is installed and working as I get a display both from the Amiga RGB port to my CRT TV and to the Dell through VGA. I read the docs that says the tool requires KS Rom 2.0... is this the minimum or does it only work with kickstart 2.0x?

    EDIT: I tried setting Workbench to run on NTSC Hires laced thinking that maybe the tool wanted the screen to be in a native Amiga mode but this made no difference. (I usually run Workbench in Picasso96 RTG through the Vampire HDMI.)

    Amiga 500 (OCS) with 1mb CHIP
    Vampire 500 v2+ core 2.10

    OS 3.1.4 (Rom patched into Vampire.)


  • The video mode of the workbench shouldn't matter for ECSv2 detection.

    My educated guess is the Vampire 500 blocks access to the required configuration registers.

    Did a bit of searching and found this wiki page:


    iComp Indivision ECS Yes Configuration tools not working; Graffiti mode not working

    I do not own a Vampire and know little about the inner workings. So I'm not sure if the Vampire can be switched to some more compatible or transparent mode. It should allow writes to $DFF1F2 and $DFF1F8 and reads from $DFF1F4. If the Vampire blocks or remaps one or more of these three (reserved) chip registers it causes the problem you describe.

  • Looks like I will have to take that information to the Apollo forum and see if they can confirm what the Vampire is doing. Thank you!

    I will be fully disassembling the 500 at some point soon to do some work to make the joyport multiplexer socketed (I have done this on my other 500 already) so I may just put my 2.04 rom brom back in with the plain 68k and my GVP Impact II scsi drive and configure the Indivision before putting it all back together.

  • Have a Vampire 500V2+ in A2000

    ...same solution: Go to the vendor of the accelerator and have them free the path to the registers of our product. There is no reason to block these registers in an OCS/ECS machine.

  • Gunnar Wrote:

    Please check the Vampire hardware compatibility list:


    The reason the Indi-config tool not works is that

    both Indi and SAGA use overlapping registers.

    There is no fix to this.

    Bad for all with this config, thank you for your Support Jens

  • Sad to hear that the makers of Vampire are not willing to free these registers temporarily with a small tool. Indivision ECS V2 uses a carefully selected unlock sequence that Vampire/SAGA could detect and thus make the thing compatible.

    The good news is that the configuration is stored inside Indivision, and once stored, there is no need to access these registers any more. So a workaround is to remove that incompatible accelerator, do your configuration, store it and then re-install the accelerator.

    This is where Vampire could hide their SAGA registers and let accesses pass to Indivision ECS V2. The second unlock sequence:

    1. =====================================================================
    2. To access flash send following unlock sequence to $DFF1f8
    3. $E000
    4. $C000
    5. $8000

    One more time, this is where Vampire could hide it's SAGA registers and pass info to the actual chipset. As soon as the lock-access:

    1. $F??? to $DFF1F8

    is seen, you know that Indivision ECS V2 is "silent" and access can be routed to SAGA again.

    See, there's always a way if you really want to. The FPGA size of Vampire is large enough to implement this tiny sequencer.

  • There has been an even easier suggestion on a1k.org, and that's using register mirrors. Please relay the following information to the Apollo-core team:

    The Amiga chip registers are mirrored many times, and the conflict may be solved easily if our config tool uses a different mirror. My suggestion would be that we move "one step higher", so instead of using offset $df.f000, we'll use $df.f800. I can see that SAGA already uses the different mirrors of the chip registers for more registers, so it should be easy to declare anything above $df.f800 as "must be passed to the original chipset".

    This may already be in the Apollo core, but before we do the change on our side, it would be nice if we get feedback from Gunnar about his will (or lack of) to free this address space.

  • Answer from Gunnar:

    Gunnar von Boehn
    (Apollo Team )

    I would need a complete list of INDI ECS register plus the information are they poked to by the Copper, by the CPU or both.

    Hi Jens, i think the best way is now contact Gunnar

  • I did send him an eMail a few days ago already. No answer yet.

    The config tool obviously only accesses these registers with the CPU. We could of course take the detour through copper and bypass the Vampire that way, but the solution with opening one of the mirrors is a lot easier. Gunnar not responding to that very suggestion feels like a delay strategy.

  • Hi i have just tried the new version and it wont open - it tells me no Indivison found, this is on a A600 with a vampire.

  • Another customer with A2000 reported success. Maybe different cores on different versions of Vampire?

  • ok so after some further testing - I was able to update the indivisions firmware, and now run the config tool - however it still isnt really usable as it seems to freeze the amiga when selecting to test any given screen mode. however it seems its going in the right direction!

  • Hi i have just tried the new version and it wont open - it tells me no Indivison found, this is on a A2000 with a vampire 500v2+ core 2.11

  • i have now put indi back in my A500 Rev6 , have flash with rescue disk --> Screen goes black -- hmm i start then flashtool flash firmware --> Load anything in the Background from Disk then System Crash, Leds from Power is Flashing. And now? I think i must send my card back to Jens. Blind flashing is no option more in my case.

  • I'll get it downloaded and tested this weekend.


    v1.7e is working on my A500 with V2+. I am running the Gold Core 2.10 and related SAGA drivers if anyone else is interested.

    Thank you for the update! It made a huge difference to the quality to be able to adjust the filters.

  • Version 1.9 of the Indivision ECS V2 config tool works fine on my A500 Rev 8a Vampire 500 V2+ with the 2.11 core. Happy I am....

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.