Micromys V5 erratic behaviour

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Jens and team,

    My setup:

    A2000, OS 3.1, buddha ide - cf card + cd rom, megachip, 6mb ram card, ecs v2, lyra, micromys

    My mouse movement is not fluid. It is difficult to use the system effectively and I'm getting a bit frustrated.

    This was not always the case. This is a recent occurrence. What changed? ...

    I added a cdrom drive to my system, I removed the 68030 card (it's on temp loan to someone) - currently rendering my RTG card disabled.

    And I also added the micromys driver to the system - note, I also did a quick test by removing it.

    It made no difference. I removed the cdrom drive. Again, no difference.

    The mouse jitteriness is more prevalent is some specific apps. For instance, it's bad very in Pro Draw.

    Any ideas as to what may be causing this?


  • I'd check the simple things first: Optical mice are really great if it comes to maintenance, as they require almost none. However, if for some reason a hair got caught int he optics, the behaviour is really erratic. Try cleaning the optics and make sure that the surface you are using for the mouse has some visible structure. Optical mice will fail on shiny single-coloured surfaces.

    A bad connection may also cause this - if the PS2 startup-handshake starts over and over again, you'll notice frequent hickups of the mouse.

    Removing the accelerator has reduced load on the power supply, taking it into a different load situation. This may have changed ripple to a point where the microcontroller within Micromys is crashing frequently. Try increasing the load with an old harddrive or two, just to rule that out. If that helps, exchange the output caps of your power supply.

  • Jens,

    I am also having issues with my CDRom (connected to the Buddha controller). Sometimes the boot sequence detects it, and sometimes it doesn't.

    It occurred to me that I recently upgraded the firmware on my RTG card (ZZ9000).

    This evening, I removed the card from the Amiga. It appears the jitteriness is gone. Mind you, I did not spend enough time on this issue (lack of time on weekdays) and will review further on the weekend. I am suspecting there is some sort of conflict being caused by the RTG card. There is one configurable item on the card - whether or not to use IRQ 2 or 6. I have no idea what it does. I tried both options and there is no difference.

    I reverted the firmware on the RTG card. The issues remain (cdrom sometimes fails detection, mouse jiterinness).

    There is some conflict being caused by the RTG card which wasn't visible and/or present when the 68030 card was in the system.

    As for the CDRom, this was a recent addition to my setup and was never used with my 68030 card.

    I will speak with the RTG card manufacturer. Can you please tell me whether or not the Buddha or Micromys use any of the interrupt lines.


  • I am suspecting there is some sort of conflict being caused by the RTG card. There is one configurable item on the card - whether or not to use IRQ 2 or 6. I have no idea what it does. I tried both options and there is no difference.

    The Amiga uses shared IRQs, so there should be no difference. The Buddha uses INT2, but if you didn't observe any difference, then there probably is no conflict. I trust that Lukas has implemented IRQs the right way in his product.

    Micromys by itself cannot use one of the IRQ lines, as the pin is not available on the port. Only the wheel driver uses an IRQ, but that's the VBlank of the Amiga itself, not a physical line that is used by Micromys.

    As you can see on many solved cases in this support forum, there is a large number of cases solved by checking the power supply. Flakey behaviour points to high ripple on the +5V rail, so one of the first things I'd do is to measure the 5V rail with an oscilloscope. These problems may occur "from one day to the other", as with more expansions, you probably have more fun using the machine, and you use it more often. This wears out the 25-year-old capacitors even more, until their performance just goes downhill, hence the observation of immediate failure without warning.

  • I suppose I can rig up a PC power supply

    Please don't - at least not before reading up on how to tell if the 5V rail is the main regulation rail. Most of today's PC PSUs are "mostly 12V PSUs", because all the big consumers (like CPU and graphics card) have local regulation these days. An Amiga has almost no load on the 12V rail, and with the classic design of most PSUs these days, this results in poor regulation of the 5V rail - which is what the Amiga depends on the most.

    You better have the existing PSU serviced with new output capacitors. Or you try Micromys on a known-good Amiga first - after all, we want to find out which part is acting up here: The computer (with it's PSU), Micromys or the mouse itself.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.