Indivision AGA Mk3 HDTV Audio

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Actually I just used a dB meter app on my iPhone which tells you the decibels coming in to the iPhone microphone.


    But I took the above as a challenge. So I created a 440 Hz test tone WAV file, and played it back on the Amiga through its line out and HDMI as well as from a Mac using HDMI using another Mac's line in to record. I didn't bother setting the gain to anything specific, so don't pay attention to the absolute volume. Results:


    Amiga HDMI: -20.041 dB

    Amiga line out: -12.866 dB

    Mac: -7.425 dB



    So the HDMI out is still 8 dB lower than the Amiga line out and 12 dB lower than the Mac. So it's strange that at this level you are getting close to clipping. I used Play16 and didn't pay attention to the settings so maybe it wasn't playing back at max volume, though. But of course that equally applies to the Amiga line and HDMI outs.


    (I can upload the recordings if that's helpful.)


    I should have thought of checking whether the Mac uses 16, 20 or 24 bits, but I just plugged back all the cables... Still, if the Mac uses more bits then those should be at the low end, not at the high end so the volume can get louder without clipping...


    I also tried to record the audio digitally through my HDMI capture dongle, but for some reason the audio didn't come through.

  • So the HDMI out is still 8 dB lower than the Amiga line out and 12 dB lower than the Mac. So it's strange that at this level you are getting close to clipping.

    With all the analogue amps in the chain, it's hard to verify the method of measurement. We can't do more than use the whole digital level, but I have to admit that we have no way of verifying if the HDM! encoder chip converts the data correctly. The only way to find out would be to decode audio from the HDMI stream again, but I have no equipment to do that. What I did was to acquire a pretty recent Denon Receiver with HDMI inputs - the unit does lots of audio processing and has a huge display, and I hope that it will also show me the incoming audio level.



    I also tried to record the audio digitally through my HDMI capture dongle, but for some reason the audio didn't come through.

    Please try different output sampling frequencies. We've had the topic before, and depending on the capture device you need to change the sampling frequency. So far, most devices were compatible with 96kHz, but some required 44.1kHz.

  • Please try different output sampling frequencies. We've had the topic before, and depending on the capture device you need to change the sampling frequency. So far, most devices were compatible with 96kHz, but some required 44.1kHz.

    I tried everything I could think of, and nothing worked. (Rebooting, different computers, different cables, different settings, I even downgraded the MK3 firmware.)


    It seems my CamLink 4K is very picky about timings, and maybe it doesn't properly recognize the audio where my monitor does. You basically get a small beep every second or so. But after changing resolutions, the sound is more recognizable for half a second or so. It's all very strange.