Error EXC33

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi, yesterday my aca500plus card didn't work. I tried it on two different commodore amiga with the same result. The error "EXC33" appears on the screen while it's starting up.


    EXC33


    A0 0050ED7C A1 0050ED7C

    A2 00C01000 A3 0050000C

    A4 00500000 A5 00AF1100

    A6 00DFF000 A7 00C00FF6

    D0 98D13BED D1 0000ED80

    D2 0000ED70 D3 00000000

    D4 00000000 D5 B4FFB9FF

    D6 FFFFFFFF D7 00000000

    PC 00BA0C7A USP 8FDBF7FE

    SR 2704


    I bought this card in individual computers in February 2019, I would like to know if it is under warranty and what are the instructions to follow.


    Thank you.

  • Please try to clean the expansion slot first - it might be a simple contact problem.


    Further, did you only try two different Amiga comptuers, or also two different power supplies?

  • Hi, thanks for answering.


    I have two commodore amiga to try out: one is modified with a gotek and the other is unmodified.


    The card has been connected for over a year without problems, suddenly it stopped working.


    I've cleaned the connectors. I tried two PSUs. I keep getting the same errors.


    The commodores work without the card connected.


    Please, what does this error code mean? What can I do? Is the card broken?


    I can't upload the photos because their size is too big, few links with the photos with the problems and with the two commodore working.

    [external pictures deleted - please downsize and upload here]


    Thank you.

  • Please do NOT use external picture hosters - they are only temporary, and if someone finds this thread later, they might be gone and information of this thread is incomplete. Please learn how to downsize pictures for upload here.


    If you have tried "two different" PSUs, what type exactly are they?


    The error code is a CPU exception. You may want to try going into de-brick mode to see if the computer comes up then. Press and hold the DisMo button until you see "0_" (with the underscore blinking), then do a keyboard reset.

  • OK, the 2.5-amp PSU has better overload behaviour, and the 3-amp PSU has better ripple. In any case, both are on or at least near their limit, so they could use some service, such as exchanging output caps.


    I followed the "De-brick" method, the Amiga starts normally, but on the LED the "E0" error still appears.

    The "E0" is displayed by the exception handler, so "something" is causing the CPU to execute non-working code. What you could now try (again, using de-brick mode) is to re-flash the unit. All flash updates actually come as ADF files, so they may be used for both flash methods: THe regular one from the menu system, and for de-bricking using a floppy disk. So please take the latest menu update, write the ADF to a floppy (or run it from a Gotek drive) and then boot from that disk after you've entered de-brick mode.

  • Can the flash memory be erased in other situations?

    it normally takes specific software to execute a "write" to flash, so I have no idea why your flash has lost it's contents. If you experience the same when running a specific piece of software, we can of course try to analyze that.