MMUlib - install or not for OS3.1.4 with ACA1233n?

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.


Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Machine - A1200

    Card - ACA1233n-40

    Internal ROM - 3.0

    Workbench - 3.1.4.1

    ACATool - 2.1


    Hi,


    Having just completed a 3.1.4 install I noted the warning from Hyperion re CPU libraries:



    And having just encountered an error trying to get a WHDload game running, I wanted to rule out everything including turning off features using ACAtool, and / or installing anything I might have missed re drivers/libraries etc.


    Checking your forums to see if MMUlibs had been mentioned, and if I should install or not. I found the following threads which leads me to ask is there a recommendation re adding the MMUlib from - http://aminet.net/package/util/libs/MMULib ?


    2018 post discussing 3.1.4 & MMU libraries:

    ACA 1232 and AmigaOS 3.1.4 - where do I find the 68030.library?


    29th March 2020 - user mentioned using MMUlib to resolve issue bad was on old tools:

    Unable to map internal kickstart on ACA1233n-40


    2nd April 2020 - Post saying don’t use MMU library:

    Acatool MAPROM breaks when setpatch is called


    Appreciate your thoughts on this one?


    Regards,


    Ross

  • Thor's MMUlib is great, but has the disadvantage that ACAinit (which is not our tool) blocks access to the registers that our ACAtool requires.


    Whatever the WHDload error was, I see very little chance to resolve that with the MMUlib.

  • I have run the latest ACAtool but I also get the Hyperion warning on startup and my ACA1233n shows the MMU as 'not working' in Sysinfo.


    Shouldn't I install the additional libraries?

  • Sure, if you want to run software that depends on MMUlib.

    I see no compelling reason for using MMUlib with a 68030 card just for the sake of it.

    Both should be fine. Both the latest ACATool and ACAInit (from MMULib) should take care of it.