Reloaded mk2 stopped detecting VIC and CPU chips

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi all! I've had my Reloaded mk2 for about 2 years now and it's been working great! This morning I plugged in my MSSIAH cart and noticed the power wasn't coming on at all. I've seen this before and usually taking it out and reinserting the cartridge (with the the power off) tends to fix it. But it didn't this time, so I kind of lifted the cartridge up a bit while the power was on (yes, I know, that's probably not a good idea) then the power light started blinking. I connected ti the BIOS with my laptop and when I list chipset into it now can no longer detect my CPU or VIC chips. The SIDs are both still detected fine. I've got a multimeter and such to do some tests but how should I go about this? If I had to guess a voltage regulator may have been blown since the fuse is still closed. Any suggestions on what I should do to try and debug this?



  • as a first step, find the pinout of the various ICs (CIA/CPU/VIC/SID) eg in c64-wiki ... and measure VCC, it should all be 5V. if that is OK, you may want to check the ICs in another C64 perhaps

  • Please also take a picture of the cartridge slot with good lighting and post it here. I have a feeling that contacts inside the expansion slot are mangled and are now making a short to a neighbour or the other side.

  • Thanks, Jens, I had a feeling something odd happened with the actual cartridge slot because the cartridge still works in my C128 and a bread bin C64. I will take a pic as soon as I can and post it.

    So today I didn't have much time for more troubleshooting, but I was able to pull the CPU out and put it in my bread bin and it didn't boot at all. I took the known good CPU from my breadbin and put it in my reloaded mk2 and it was still not detected. I put the CPU back in the bread bin and it still worked, so the board isn't actively blowing up CPUs, which is nice.

    I wasn't able to check the VIC the same way since I didn't have time to verify that my breadbin was able to provide the proper voltage but I'll continue testing and keep you all updated. Thanks so much for the support!

  • I took a goods look at the cartridge port with my shop light on and there was nothing in there at all. I did a voltage test on the 5v pin on the chips and I'm getting 4.9v on the CPU and SID chips and 4.76v on the VIC chip. Does this seem a bit low?

    Also, I swapped in a known good vic chip and it also was not detected.

  • Does this seem a bit low?

    That's OK - the filtering in the supply voltage does take it's toll, but it improves picture quality a lot.

    We need to dig a little deeper now - can you send the output of the remote control menu for the chip set detection?

  • This may be a simple contact problem. Please make sure that you really use the levers the right way: They are open when the levers point up. Then insert the chip and push the lever down; it does work sometimes if you do it the other way round, but contact really isn't safe.

    To make sure that pins didn't oxidize in the mean time, just try to shift the chips sideways in the ZIF sockets while the lever is closed.

    If all that fails, we can of course take a look at the board here. If you ship it from outside the EU, please make sure to declare a value of under 20 dollars for "defective hardware" (after all, that's what it really is). This will help getting it through customs without me having to drive to the customs office and back (that's a 2-hour round trip).

  • Well shoot, that didn't seem to do the trick either. I can go ahead and send it to you all see what you thin. I'm more than willing to pay for repairs. Do you need to me to include an RMA number or something? And should I send it to the same address you sent it from?

    Thanks so much again!

  • Yes we only have a single address.

    1. individual Computers Jens Schönfeld GmbH
    2. Im Zemmer 6
    3. 52152 Simmerath

    You don't need a RMA number, but please make sure to include a short note with a description of the problem in the package.

  • Yes, it's here for pretty exactly two months now. Need to find out why it wasn't repaired yet - we do have a lot of work with the currently-running production of Indivision AGA MK3, but that should not cause delays like this.

  • This has been repaired, but we're waiting for DHL to lift their idiotic&greedy "danger pay" before shipping this back. We've already signed a contract with a new carrier for shipping, but need to write a new interface for our shipping system. We'll do our best to ship this out before our company holidays (starting this Friday).

  • I am having the exact same problem. I bought the board two years ago and never got it working until at friend helped me update the software. But now I have known good chips in it and it doesn.t find the VIC-II to be good. Why?

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.