RapidRoad on Xsurf-100 only works when the card is in Z2 mode

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
  • Hey all,

    first off i thought this was a problem with my mediator board in my A4000. But i've been having so many issues with the mediator, i've decided to pull the mediator card out completely and put the original Zorro backplane daughter board back in.


    anyway. setup as follows.

    A4000, 3.1roms, buster Rev11, normal A4000 Zorro busboard installed

    A3640 040 cpu

    16meg ram on board

    Cybervision64/3D in the bottom slot

    Xsurf-100 in the 2nd from top slot.


    I've not tried a different slot yet, i spent so much time faffing with the mediator last night before deciding to pull it out completely that i haven't really had time to play properly.

    so. the xsurf-100 runs absolutely fine in Z3 mode with OS3.9 and a paid version of Roadshow.

    place the RapidRoad card on the board, the light comes on as normal, machine boots fine, start up Trident and it complains that some things couldn't start up something about the "hardware enumerator wasn't talking" if i recall (in the mediator, Trident would just crash at this point).

    switch the Xsurf-100 to Zorro2 mode, and everything is absolutely fine - same on the mediator.


    I also have an A3000 with almost the exact same config, except it has a CyberstormMK3/060+128meg for CPU, a Zorram256, and it's Xsurf-100+rapidroad setup runs fine in Zorro3 mode. same workbench/OS/IP Stack setup. So i'm a little puzzled... :/


    i don't care too much, just i had to dump 1.4gig of video from a USB stick and i had to leave it to copy overnight. It's just annoying knowing the potential is there for higher data rates. Would mean i could run stuff direct from USB rather than having to copy it to local disk first.... i dunno... any thoughts or ideas most welcome

  • Please make sure to use the latest version of the device driver, and also install Thor's MMU libraries. In this combination, the driver will "ask" the MMU library to poke a hole into it's protective layer and it'll also work in Z3 mode.

  • Managed to slot a bit of time this evening:-

    ok, so downloaded the PoseidonV4.5.lha from here, and copied over the rapidroadxs100usb.device into devs:usbhardware

    version of the rapidroadxs100usb.device is 1.6

    downloaded mmu.library (and installed) pack from aminet

    version of Libs:mmu.library is 46.18

    Xsurf100 set to Z3 mode.

    opening Trident I get:-

    Warning - Poseidon.library - GET_DESCRIPTOR (len8) failed: nak timeout (10)

    Failure - Poseidon.library - SET_ADDRESS failed: nak timeout (10)

    Failure - Poseidon.library - Device enumeration failed, sorry.

    Failure - Poseidon.library - Root hub enumeration failed. Blame your hardware driver programme


    so removed and re-created the Controller in Trident. hit online, and then restart to restart the USB stack... same result.


    must be something i'm missing here.

  • yup. I'm a plumb. I didn't see the RR 1.7 Driver pack on the website. that's nailed it! many thanks.


    btw, speed of an 8gig Sandisk Cruzer Blade USB key has gone from 2meg to 6.5megabytes per second in sysinfo, and 1.6MB/s to 3.9MB/s in SysSpeed!


    awesome, thanks again :)