ACA1221lc Not booting

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Received my new ACA1221lc today, but I'm only getting a yellow screen at boot.

    I've done the typical things, like the cleaning (with a pencil eraser) the contacts and re-seating it several times with no luck.

    I have also removed things like the sd-card ide, as well as confirmed that it boots fine without the accelerator.

    The machine is an Amiga 1200, rev 1D4

    I have several other Amiga's (500/600) but I don't have another 1200 to test the card on. However, I'm lucky enough to have a retro computer repair shop near where I live and I will reach out to them for assistance.

    In the meantime any suggestions would be helpful.

  • There are more "typical" things that you should try - for example not just re-seating, but puling it back by about 1mm after plugging it all the way in. Sometimes the edge of the A1200 CPU slot is not bevelled, which causes contact problems if it's all the way in.

    Further, we experience lots of power supply-related problems lately. If you have several Amigas, then please try the other PSUs you have.

    If that doesn't help, please describe the whole system, including all internal and external expansions. I have my doubts that the card is dead out-of-the-box, as we do test every single board before it leaves here.

  • I'm also suspicious of the A1200, it has taken some effort to restore to working order. I'm trying to be hopeful that we don't have more work to do.

    - I tried your suggestion to move it out a bit. No change.

    - Both PSU's I have are identical A500 ones and are pretty old, I tried them both with no luck.

    - I've removed everything from the board (SD reader, Gotek Drive, CF Card).

    I have had Meanwell RT-50B sitting on a shelf waiting to be used for a while now. I will get that into working order and give it a go.

    If that fails I'll do some tracing on the expansion connectors and look for anything out of the ordinary.

    Thanks for the quick response. I'll keep you posted with any progress.

  • I have had Meanwell RT-50B

    That's no good for an Amiga. It lacks important regulation mechanisms required for the long cable between PSU and the Amiga. We have lots of support cases where MeanWell PSUs are involved. Most, if not all of them were solved by going back to the original PSU.

  • hunt down an alternate PSU

    Note that all 3rd party PSUs that are offered are also based on Meanwell PSU chassis. I recommend borrowing a known-good PSU from a fellow Amigan.

    We'll offer a good PSU solution for A500/A600/1200 soon, which addresses all problems that the currently-available PSU are causing.

  • I have almost the same problem power ligth turns on but my A1200 doesn't boot at all.

    Screen turns on but nothing happens.

    I have 3 Amiga 500/1200 power supply's and tried all of them.

    No boot.

    Also tried the 1 mm thing.
    Did not work.

    Amiga works fine without the ACA1221lc

    Please give me advice.


  • Please take a micro fibre cloth and clean the A1200's CPU connector with IPA on both sides. We've had the second case of an accelerator returned to us with this error description, but it works just fine here on several different machines.

    Also, please take a close look into the CPU connector of the accelerator: Are there any pins bent?

  • I cleaned the cpu connector with IPA and tried to start it without HDD mouse and df0 but I don't even get to the kickstart screen.

    It is a v1d4 revision and it is in working with my memory expantion.

    The jumper is not installed, is that the problem?

    All the pins look good, not bent.

  • The jumper is only for de-bricking - the unit is considered "bricked" if you had a power failure during flasing. If your computer has never worked with this card and the power LED never changes brightness after powering on, we need to take a look at the card here.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.