ACA500plus holes in memory map

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hello!


    I'm a happy owner of an ACA500plus, and have been successfully using it on few of my Amiga 500s. A while ago, I connected it to an A500 Plus that I just bought. Everything worked fine, without one of my AmRAM-16 512KB memory expansions plugged in. Once I attached the memory expansion, the Amiga started going nuts. Amiga Test Kit crashes immediately, all WHDload games crash and some crash with a red screen, Workbench desktop "jitters" and has graphical glitches.


    All of my regular A500s still work perfectly fine, with the ACA and memory expansion attached. My A500+ works with ACA, without the memory expansion, or with the expansion but without ACA.


    But now, in Amiga Test Kit's "Direct Memory Scan" portion, there's this warning "12 holes in memory map??", that wasn't there when I first started using the ACA. This warning shows on all of my machines now.


    Has my A500+ somehow messed up the ACA?


    -Mikko

  • Please open the computer and double-check that there is no expansion fitted inside the computer. This looks like an incompatibility, or possibly a leaked battery of the A500+.

  • I double checked that there is no expansion inside the computer. I still get the same "holes in memory map" warning, with the ACA attached. This happens with both, the A500 and the A500+. Both memory tests (Kickstart and Direct) still come out clean, despite the warning.


    With the ACA disconnected, I don't get that warning on either of the machines.


    The A500+ has had some very minor battery leakage, and couple of the traces going to the expansion port are a bit corroded. I checked all of the pins on the expansion port, for continuity and they were all good. At least I heard a beep every time. I'm pretty convinced now, that the expansion port is still defective on the A500+ and might have damaged the ACA.


    The following combinations seem to work perfectly fine, despite the warning:

    -A500 with ACA and memory expansion

    -A500+ with just the ACA


    The question is, should I send the ACA for repairs because of the "holes in memory map" warning? Of course I'd like it to be in perfect shape, like in the beginning.

  • I don't even know what the error message means - it's not a common term to use in a memory test program.


    Please download the MBRtest2 tool - that's a very good memory test that was shipped with Microbotics memory expansions back in the days. The utility disk can be found here, for example:

    http://amiga.resource.cx/exp/mbx1200


    Please run the tool, enable all memory areas that are seen by the tool and run a few of the tests. Does it report any problems? If not, my guess is that the test you're using is no good.

  • I did the test and it came out clean, but didn't detect the fast RAM on the ACA. Is this normal?


    The attached photo shows the results with a memory expansion attached. I found a Roctec RM550C-F module from my stash, that seems to be working fine with the ACA. I guess there was a compatibility issue with the AmRAMs. I also ran the MBRTest with the expansion switched off, and there were no errors either.


    The only problem now, seems to be the fact that Amiga Test Kit's Direct Memory Test shows the "holes" warning, that wasn't there when I first tried out the ACA. Everything seems to be working fine though. So I guess there's nothing to worry about?

  • MBR-test should see all memory that is in the freemem list. Your screenshot indicates that there's only trapdoor memory. Maybe you've just not enabled fast mem? Did you launch the system with one of the cloaking device options?

  • No, I didn't launch the system with any of the cloaking device options. In fact, I've never even looked at the cloaking device menu. Workbench, ATK and SysTest all see the fastmem, but MBR-test does not.

  • Funny - I have never used MBRtest-2 with the plain ACA500plus. I can reproduce the non-display of the 7M fastmem block.


    What you can do is to go to the "Ramtests" directory and edit one of the projects given for non-added memory. To do that, click on the icon once, then choose "information.." from the drop-down menu. You then edit the address to be 00401000 and the size should be 006f0000. You may have to edit the path to the mbrtest-2 program in the icon as well - at least I had to do that on my installation (which might be b0rked).


    MBRtest-2 will then show that memory space as "specified memory", and you can run all tests on it.

  • Sorry for the delay, I just got home from a week long trip.


    I couldn't find the Ramtests -drawer anywhere on the disk, and I even unpacked the MBX1200.dms on another disk to check this.


    Anyway, I already went ahead and bought the ACA1221lc, to tackle some WHDload issues. I installed the card on the ACA500plus, and the "holes" warning disappeared from ATK's Direct Memory Scan section. I also installed a BooBip 1MB trapdoor memory expansion at the same time.


    Now MBRtest-2 also sees all of the memory regions just fine. I was watching one of RETROCENGO's videos the other day, and he too seemed to have the "holes" warning, using the ACA500plus. I guess this means, that it has to be an issue with ATK.

  • and he too seemed to have the "holes" warning,

    Maybe it's just a "warning", and not an "error" or "issue", meaning that the program encounters something that the author deemed unusual. Well, yes, the memory layout of the ACA500plus takes advantage of some things that a normal memory expansion cannot do, such as using spaces where you would normally have CIA mirrors.