ACA1211 OS Problems when approx 2- 3MB Free Fast RAM / Netgear FA411

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • Hi Jens.

    1.d4 A1200.

    IDE SDCARD Adaptor

    DH0: DOS7 FFS 46.20 MaxTransfer 0xFFE0 OS

    ACATool v2.1 Softkick kick.a1200.46.143 SPEEDY IDE=NO issue happens with PCMCIA Friendly=YES or NO

    First is trying to launch WHDload titles with a large Preload. EG WORMS AGA

    Loading proceeds, fast ram goes down but then chip ram starts to go down and loading stops, yet there is approx 3 MB FAST RAM not used but only 66K Chip left.

    Its as if the system doesn't know about ram after 8MB Fast ?

    Coping files to RAM:


    Copy a 1.3MB file to ram then rename, continue and once there is roughly 2-3 MB left fast ram the system goes into a recoverable Alert.

    0100000C 02D8A60

    Other problem is that the ACA1211 will boot from 3.1 rom, then soft kick 3.1.4 rom file OK

    However,If there is a netgear FA411 card in the PCMCIA after the soft kick of 3.1.4 rom it wont boot and sits at the boing ball insert disk kickstart screen.

    Removing the PCMCIA card and soft reboot then allows the machine then to boot.

    Now the A1200 works fine with a PCMCIA card in it with 2 of my ACA1232's 40Mhz serials 5TUby RTUUN in it also. Also with an old DCE Typhoon MK2 . So the issues to me must be with the ACA1211

    So I moved the ACA1211 to one of my other A1200's, this once has real 3.1.4 roms.

    Won't boot if a netgear FA411 is in the PCMCIA slot, remove the netgear card and it boots.

    Same happens with the low memory scenarios with this A1200 too, when you get to 2-3 MB free fast ram the recoverable alerts start.

    Now on both A1200's you can hot plug the netgear once in and then launch MIAMI DX but as soon as you attempt to tx/rx data, Recoverable alert.

    P.S. tried 3 different power supplies including a Goliath one.

    Tried everything I can think off before posting.

    3 A1200 ACA 1232 OS 3.1.4

    1 A1200 Typoon Mk2 OS 3.9

    1 A1200 ACA1211 OS 3.1.4

    1 A1200T 603e OS4.1beta

  • This must be an issue of OS3.1.4, as I cannot reproduce it under 3.1. I have just tried copying lots of files to RAM:, and stopped when only 83k of RAM were free. The size of my RAM is now 11M (according to the "info" command), and the system remains stable.

    For PCMCIA compatiblity, there is nothing you need to do if you have 3.1.4, as the ROM will not switch off the PCMCIA port when Z2 memory space is used up. Since we know this, the ACA1211 will not apply the patch if it finds an exec version any different from V40.

    You might want to contact Hyperion about this.

  • We have now been able to reproduce the issue, and we'll test a workaround (new version of ACAtool) to make PCMCIA-CF adapters work.

    Note that only PCMCIA-CF card readers cause this problem, but the most common 3Com Etherlink III networking cards don't.

    What's already clear at this point is that the cards that cause this problem will NOT be hot-plug compatible. They must be inserted on power-up, so they can be initialized by the Autoconfig-ROM of the ACA1211. Removing and re-inserting them may lead to an instant crash of the system, as they overlay part of the memory that the ACA1211 provides.

    This is obviously something that is not caused by the ACA1211. If you have OS3.1.4 and a "random" other 8MB memory expansion, you'll experience the same problem. Unfortunately, the only solution for those is to not use PCMCIA at all, as they have no ROM where PCMCIA init routines can be placed. The ACA1211 has that, and it can be updated in the field. I hope that we can provide an update to the ACAtool soon, so you can make use of the whole combination as advertised.

    I have tried to find a Netgear FA411 card, but so far did not find any. If you happen to know a source, I'd like to buy one to include it in our internal testing.

  • Thanks - we've already found one of these cards, but currently have trouble to get it working at all. We currently need to wait until our new PSUs are available, as the computer at the developer's site has been acting up on several occasions with symptoms that are impossible to explain. I'd like to exclude the power supply as a cause before we put more time into debugging this.

  • Hi Jens I've been discussing this with the OS3.X developers and even with V40 card resources I can still reproduce the issue. I've also now tried with other pcmcia devices such as the surf squirrel and a cdrom. Coping data to ram results in a crash when cd0 is mounted. As previously mentioned if I remove the ACA1211 and insert an ACA1232 40mhz EC030 the problems go away. With a PCMCIA device installed if I run a memory test there appears to be a memory overlap. Is there anyway to map the fast ram to the same location as the ACA1232?

  • Is there anyway to map the fast ram to the same location as the ACA1232?

    No - the 68ec020 CPU does not have that address space. It seems like if we can't tell the Gayle chip to get out of the way for the memory card (which the ACA1211 already does using the OVR signal), and the PCMCIA card ignores the standard command to leave the memory area, there is nothing we can do.

    Even the ACA1221lc (and predecessors) works fine, although it uses the exact same processor. The difference is that the main board doesn't even "see" the memory access, so the PCMCIA port doesn't get in the way.

  • You can try to disable the ROM first, which will not add the RAM beyond Z2 space. If that doesn't help, try an allocmem() starting $60.0000, up to the end of Z2 address space. If that makes it work, we could add that to the options in ACAtool, though it kind of defeats the purpose of a memory expansion...

  • Would it be possible use the ACA trade in then towards a different ACA card which I can use with this particular A1200 setup.

    How is that done ? Is there an ETA on the A1240/1260 boards yet ?

  • Would it be possible use the ACA trade in then towards a different ACA card which I can use with this particular A1200 setup.

    Sure, we currently have the ACA1221lc and the ACA1233n-55 in stock, and that trade-in offer is valid for both of them.

    How is that done ?

    Send it back after reading this article, let us know in your letter what card you'd like to order, and then just wait for the invoice to arrive in your inbox.

    Is there an ETA on the A1240/1260 boards yet ?

    Sorry, no release date for that yet.

  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.

    • :)
    • :(
    • ;)
    • :P
    • ^^
    • :D
    • ;(
    • X(
    • :*
    • :|
    • 8o
    • =O
    • <X
    • ||
    • :/
    • :S
    • X/
    • 8)
    • ?(
    • :huh:
    • :rolleyes:
    • :love:
    • 8|
    • :cursing:
    • :thumbdown:
    • :thumbup:
    • :sleeping:
    • :whistling:
    • :evil:
    • :saint:
    • <3
    Marks thread as resolved after post creation.