Indivision rescue disk - black screen, power LED flashing (dimming)

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hi,


    I have an issue with my Indivision ECS V2. I attempted to update using the latest rescue disk on the site, the screen went blank and the power LED began dimming every couple of seconds.


    I left it for what seemed like a really long time, as I wasn't sure if it was flashing or not as the screen is now blank. Eventually I powered down and now my Indivision is not displaying any picture.


    How long does the flashing process usually take? Is this power LED dimming/flashing normal? Thanks for your assistance.


    My setup: A500+ 1mb chip ram, no mods present beside Indivision ECS v2.

  • I see that according to the wiki:


    > Blinking once, pause, repeat: Success, all ok


    However, each time I boot from the rescue disk, after about 30 seconds it starts blinking a single time. But the screen is black. I am using the same monitor and power supply and all other configuration is the same as it was before. Note: I have tried several rescue disks.


    Please help, my indivision is dead at this point. Thanks.

  • It's hooked up to exactly the same cable and monitor as it was pre-flash. Nothing has moved. I triple checked the connection.


    EDIT: I have the capability to flash via JTAG if this helps. I would need the appropriate files for this. Thanks

  • So what does the monitor say - "no signal" or "out of range"?


    I find it a bit hard to believe that successful flashing ends up in a black screen, therefore the simple questions. One thing I didn't ask yet: What power supply are you using?


    I have the capability to flash via JTAG if this helps. I would need the appropriate files for this.

    The flash is not directly available through JTAG - that would have to be bit-banged through boundary scan, but to be honest, I don't even have a software myself that does this. Since the flash appears to be available through the CPLD (otherwise the LED would not blink once), access is still given. The flash routine looks for the chip's signature and also verifies contents before it reports success.


    If you have a software that can talk to an SPI flash through bondary scan, it would really be interesting to me. Other than that, the JTAG chain only contains the FPGA and the CPLD - the jedec file for the CPLD is not public, and the RBF file for the FPGA is the exact binary that is programmed into the SPI flash, just with the bit order "per byte" reversed. This info just FYI - I doubt that any of this is possible, as the flash routine reports success. It wouldn't do this if any of the verification steps would fail. We're surely looking for a much simpler solution.

  • Stock supply, the same one I was using before I flashed. I have also tried another Meanwell supply, no difference.


    Edit: screen says no signal. Apologies, forgot to answer that first time around

  • another Meanwell supply

    These are not suitable for an amiga, because they lack cable drop compensation. Use the riginal ones, or a power supply that has cable drop compensation. With the amount of MeanWell PSU-contraptions out there, it'll be hard to convince people to put them all to rest, but they are truly pestering us with support cases.


    So I stuck the Indivision in another A500 (rev 5) that I had and it flashed and came back to life. When I put it back in the A500+ it works fine.

    I'd like to find out what's different between the two setups. Would you mind describing the setup(s) in detail?

  • I have tested both systems at length with DiagROM and AmigaTestKit and there are no errors. I pulled out all expansions for fear it was one of them causing an issue.


    The A500+ is stock, save for using an RTC72421 instead of the older chip. 1MB of ram on the motherboard, 8375 Agnus, v2 (37.175) Rom.


    The A500 (rev5) is stock, except for a 8372a Agnus, v1.3 ROM (don't have exact ver).


    About the power supply. The Meanwell is fine for my use, I have a very accurate multimeter (Keysight.. five decimal places) which was recently calibrated. I have adjusted the trim pot and the Meanwell is like 4.99999 on the 5v line at the Amiga LF1.

  • save for using an RTC72421

    What would that mean?

    The Meanwell is fine for my use

    No, it's not. Lack of cable drop compensation means that any 3.3V-expansion will be under-powered in most use cases - that's because the linear 3.3V regulators require at least 4.85V on the 5V rail, which are not guaranted without cable drop compensation.


    like 4.99999 on the 5v line

    where was that volt meter calibrated?

  • The original A500+ RTC was M6242B, the one I have has a RTC72421B (drop in replacement with crystal, so crystal is not populated). I pulled the RTC chip just incase it was causing problems anyway, didn't change anything.


    The meter was calibrated by Keysight, I just got it and the certificate of calibration.


    Either way, I'm using the original PS - I just said I ALSO had a Meanwell that I tried.