[BUGS] Printer not found

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser. Please create an account and log in to see all content by default. This is a limitation of the forum software.

Also users that are not logged in can not create new threads. This is a, unfortunately needed, counter measure against spam. Please create an account and log in to start new threads.

Don't Panic. Please wash hands.
  • I've connected my MPS1230 to my C64 to print some novelty Christmas banners, however the C64 gives a "device not found" error when trying to access the printer on device 4 or 5. With the TC removed, the printer is working fine as expected.

    I'm sure I read somewhere that printing isn't supported, however I cannot find it in any of the documents so may be thinking of a different cart.

    Any suggestions or are IEC printers unsupported by the Chameleon?



  • That sounds really strange, i don't see a reason for why this would happen - any IEC bus devices should work fine.

    Please try resetting the Chameleon to default settings (that implies the emulated drives are not enabled) and try again. Perhaps from BASIC (*), to make sure its not a subtle problem with whatever program you are using to print.

    (*) something like OPEN1,4:CMD1:LIST

  • I've done the following to get printing working:

    Reset the TC to defaults;

    Tried to print, nothing - device not found, so power cycled the printer while the C64 is on;

    Can now print;

    Add drive in TC menu and return to BASIC;

    Trying to print hangs the IEC until I power cycle the printer again;

    Print again and it works;

    With the printer connected I occasionally get "device not found" when trying to access a newly mounted D64 image in device 8.

    I can only assume that the MPS1230 does something odd or perhaps doesn't like being the only device on the IEC bus?

  • MMh, i dont think its a problem to only have the printer on the bus. Do you have another IEC cable that you can try perhaps?

    It is a bit odd that disconnecting the chameleon makes a difference in this setup *shrug*

  • I've had this problem indeed once or twice, too. Sometimes it helped to just switch from the C64's IEC Bus to the Chameleons IEC Bus (breakout cable). Which should not matter at all, but it helped.


  • Suddenly I dont feel that alone at still ordering a new ribbon for my MPS-803 last month ;)

    I didnt experienced any problems with printing/drive, but then i only tried printing in Geos and only used this with one emulated drive (so not a true comparisation to the initial issue, but maybe related.)

    Now i tried printing from basic, and still no issue as long as i manualy start the program.

    But then i tried the filebrowser to execute a simple basic program to print 2 lines and this changed some things.

    When using plain c64, so TC with one emulated drive, no card , no turbo, only the second line is printed when executed from the TC menu, even when adding a fair ammount of delay in the first line. But not "device not found" error on printer or drive.

    When using turbo mode (full speed), both lines are printed. Drive acces to emulated drive still ok.

    I tested both about 30 times, with reset, without reset etc. The outcome is exactly the same on every try.

    I also noticed that when i use "1-4 to start with cartridge , "reset to basic" or "reset to cartridge" that a reset is send over the serial, (the printer realligns the head as if just turned on).

    When using autostart, it seems that there is no reset over the serial port since the printer isnt doing a reset.

    Afcource there is a reset after initial power-up of the c64

    In all cases i used the serial port on the C64 Reloaded MK2 (latest firmware), firmware version of the TC is Beta-9i. Printer : Commodore MPS-803.

    If needed, i can test this next week with some realdrives, still have several Commodore drives "some where in the attic" together with an original commodore 64c.

  • I am a bit lost here to be honest... not sure what to even look for and hard to reproduce without a printer....external drives work fine here, and printers should be no different anyway *shrug*

    @Slcroucher: is that a chameleon v1 or v2? what kind of C64 board? and did you have turbo enabled or not (or does it make no difference?)

    also, for a start, do NOT load the respective program using the filebrowser, but do that manually from BASIC. i cant imagine how it would make a difference - but anyway.

  • Tobias

    Changed the title of the thread from “Printer not found” to “[BUGS] Printer not found”.
  • The last reply was more than 365 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.