Random joystick issues with Indivision ECS V2

Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Howdy,

    ECS V2, ACA500plus, AC1233, ACE2

    NTSC Rev 5 Amiga 500

    So I noticed trying to play Shadow Of The Beast (1, 2 or 3) from WHDLoad or from disk that when I'm using the Indivision that I'm getting up directions even with no joystick connected.

    It's fairly constant and disabling various items from the chain (AC1233 or ACA500plus) changes the nature of how often it happens but still happens. The only time it stops it seems is when reduce everything back pure 68000 at 7mhz. I have also tried a few of the joystick testers and other games and I haven't found other situations where it's apparent. So far just during those Shadow Of The Beast games.

    However if I replace the ECS V2 with the original OCS Denise then I have no problems at any speed at all. I did some research and noticed that in the German forums there was talk about timing issues that could cause this and it was resolved. I guess a further timing change is necessary for the NTSC Rev 5 board perhaps?

    Let me know if there is any other information you need from me.


  • Please do the latest FPGA updates to the unit; we've fixed these timing issues months ago. Just download the latest config tool and save a config once, this will also give you the latest FPGA image (it's in the config tool, so no possibility to mix files).

  • For the FPGA updates do you mean firmware 05162019? I have applied that already via the tool provided on the wiki. If there's another step I could be overlooking please let me know and I'll try it out.

    Thank you!


  • Just as an addendum, I've noticed it happening with Wrath Of The Demon, Castlevania and a few more.

    I noticed in the German forums there was mention an rbf file update from January, however I just purchased the ECS v2 in the last couple of weeks. Would it have that FPGA load that you are speaking of?



  • I just purchased the ECS v2 in the last couple of weeks. Would it have that FPGA load that you are speaking of?

    The QC procedure was not changed in a long time, so even the ones that are shipped today will have an old FPGA core installed.

    If the new version does not help, we need to dig deeper. Please open the computer, remove the floppy drive and take a picture of the multiplexer chip that's under the drive, near the joystick/mouse ports. Maybe it was replaced with a "similar type" in the past which behaves different.

  • OK, we'll try to replicate the issue here with an ACE2 in that NTSC board. Might take till next week as I have a boatload of work right now. If you can spare the time, please try to replicate the bug with one of the old Agnus types, as that will give us valuable hints.

    Just for completeness, and because your system is fairly high-loaded: What's the power supply you're using?

  • I am using the original Amiga PSU, it's had no modifications to date that I know of.

    Sure no problem on the time, I'll see about using the other Agnus chips and get that information for you.

    Let me know if I can help any other way

  • Hi Jens,

    Sorry to bother but just wanted to check in to see if you've had any time to look into this?

    Thank you!

    I haven't messed around with it myself as I haven't got a good tool to remove the gary adapter from the ACE2 install and I don't know if you can use the other Agnus chips with that gary adapter in use.

  • I figured I'd bump this thread since I have been reading in the german forums about a similar problem. I just wanted to clarify that his situation is not the only one. I also have an A500 that has joystick issues when using the Indivision ECSv2.

  • I just wanted to clarify that his situation is not the only one. I also have an A500 that has joystick issues when using the Indivision ECSv2.

    Like I wrote in the German thread, I cannot replicate the issue here, and I'm waiting for the person to send his A500, so I can investigate what's going on. I already have LOTS of A500 boards here, and the different revisions have different timings, but none of them is behaving the way that you or the German customer is describing.

    I'm willing to fix this, but before I can do that, I need to replicate it.

  • Hi Jens,

    Just wanted to say I tried the latest update for the ECS2 on my board and sadly the joystick constantly pushing up is still a problem for me unfortunately. Hopefully one day it will get figured out, I definitely understand you're a busy man and well 2020 and all that too.

    Thanks again for your continued efforts

    Happy holidays and a prosperous new year!


  • Best advice I can give here is to change the 74LS157 on the board. We did have quite some trouble with these chips from Mitsubishi, but these issues were fixed with the latest update. Your combination of NTSC board and TI as vendor for thie LS157 chip may have more implications that we can't reproduce here, so I'd suggest to just try a different vendor of this chip, or even a different logic family, such as 74HC157 or 74HCT157. Both are 100% finctionally equivalent, but will all behave slightly different in terms of timing.

    I guess you did not only install the latest config tool, but really chose the "update firmware" menu item from the drop-down menu? This is mandatory, otherwise the new core does not take effect. Please double-check this before soldering on your board :-)

  • Indeed I did verify the firmware was updated both from doing that step and seeing the date change on the OSD as well.

    Alrighty well it's something to try so I'll order some parts for the new year and give it a go.

    Thank you for the advice and I'll let you know how it goes.