Caution: Non registered users only see threads and messages in the currently selected language, which is determined by their browser Please create an account and log in to see all content by default. This is a limitation of the forum software.
Don't Panic. Please wash hands.
  • Hello,

    I finally go around too connecting my ACA500Plus yesterday and it worked great.:thumbup:

    I then disconnected it and in my haste stupidly connected it upside down.

    The Amiga 500 I used still boots to Kickstart pic and another Amiga 500 works the same.

    On both my Amiga 500's the ACA500plus starts with the cycling LED on the dismo then counts up to 6

    then gives me an E5 message with diaognal green lines on screen.

    Im guessing ive killed something,Is this an easy repair.

    I'm in Australia so postage is a pain but im willing to pay all costs if its repairable.

    Thanks in Advance


  • That depends on the version you have - is it the current version with the small 68sec000 CPU that is guaranteed to work up to 21MHz (big DisMo), or the previous version with 68ec000 CPU that is guaranteed to work up to 14MHz (small DisMo)?

    The new 68sec000 version has two protection diodes that limit the damage if connected upside-down. The older version would be a lot harder to repair, as the 9572 CPLD and the DisMo need to be exchanged. On the newer version, only two resistors near the 86-pin connector need to be exchanged (labelled "resistors of shame").

  • Hi Jens,

    Thanks for the reply.

    I can see no resistors near the connnector labeled 'resistors of Shame' so I guess its the older one.

    The DisMo display is 25mm wide x 19mm High and the 68SEC000 is approximately 13.85mm Square.

    The CPU is marked MC68SEC000F010



  • OK, you have the new version, and there are resistors of shame. Look at the corner between the 86-pin connector and the CF card slots: The two big black rectangular parts are the protection diodes and the two small parts at the bottom left of the trashcan symbol are the resistors of shame. The label is under the connector's pins, might be hard to read.

    Replace the two resistors with new 22R resistors, and the board is going to work again. Any technician should be able to do that.

  • Hi Jens,

    You were correct, 1 of the resistors of shame had been killed.

    I replaced that one and card booted straight up again.

    Thank you so much for your help.



  • Code
    1. Hello, on my 2 Aca500plus the platoon game never works (CRASH WITH WHITE SCREEN) as well the original floppy disk into original drive or with the game under WHDLoad but without ACA500PLUS the game works correctly with of course orginal disk...
    2. With Orginal Disk in DF0 drive on my A500 Rev6.A with Kickcstart 1.3, I Use Standard A500 Profile Menu with Kickstart 1.3 with 512+512k. When you start the game in the jungle after a few seconds this message start and you need to restart the amiga.
    3. With WHDLOAD at game start this message will come :
    4. Exception "Illegal Instruction" ($E010) at $8766 occurred .... but with my real A1200 all works correctly...
  • I'd expect the original game to require the trapdoor memory expansion - you should not disable that, and you should not enable 1M Chipram, as that was unlikely back in the days.

    Other than that, why not install WHDload for your ACA500plus? That usually wipes away all compatibility trouble.

  • Hi,

    Finally I return to You to explain something...

    After few months and multi tries, I finish to play with Platoon game on my ACA500PLUS without any problems.

    In fact, this game only works correctly with a CPU SPEED @28Mhz, I tested it at @7, @14,@21 (A500 Built-in Profiles at in Expert Options for WHDLOAD.

    With WHDLOAD v18.5 & OS with the latest slave of this game it's the same way... only at speed @28 MHZ can play this game without any messages errors from WHDLOAD environemt.

    But I can't usually use my ACA500PLUS @28 MZH because other problems with others games on that speed.

    If You want You can Try Yourself, You can download the game on IPF file on convert it HFEv3 to mount it on a Gotek Drive with firmware HXC or FF... Cortex firmware can't use HFEV3 file....

    (link removed) to download the game (US version but it works with PAL or NTSC)... I have try to with my Original Game Disk (PAL Version Hit Squad)....

    (link removed) to convert IPF file on HFEv3 file

    But I can tell You that it's anormal to play with this game @28 MHZ because if I completely remove my ACA500Plus the game works with the same A500 68000 @7MHZ...

    As I have a second ACA500PLUS on a other A500 Rev 6A with the same config and OS , I tested it too but with the same results...

    In that case, I think that there is a problem with ACA500PLUS firmware because all other games works @ normal speed @14 MHZ.

    my config is A500 REV 6A (512+512k TRAPDOOR) WITH ONLY ACA500PLUS AND WITHTOUT ANY OTHERS additional card... Firmware 0.135 from (september 30th, 2019) for my both ACA500PLUS.

    I hope that You will resolve my problem with an updated Firmware.

    Many Thanks,

    Best regards,


  • I have removed the download links from your posting, as I don't know about the legality of them.

    I think that there is a problem with ACA500PLUS firmware because all other games works @ normal speed @14 MHZ.

    It's normal that a few games don't like the different speed of an accelerator. It is not part of the official product support to get games working - especially not if you can get them to work @28MHz, as you're writing.

  • Hi,

    Many thanks for Your answer...

    This post was only to inform you of the real problem with Platoon game and to

    to get feedback from other ACA500PLUS users

    About the same problem with WHDLoad slave, I personnaly alerted CodeTrapper, who wrote the Platoon slave for WHDLoad.

    He is looking for a solution to try to make the Game compatible on the ACA500Plus but he cannot promise me anything.

    Personally I find that the ACA500PLUS remains a very good product ....

    I would still like to know if there is a way to completely neutralize the ACA500PLUS without having to physically remove it from the computer. If it is not already programmed, don't you think it would be interesting to include a similar function in the firmware in order to guard against possible others problems.

    Best Regards,


  • That's really interesting - especially because there is literally no way that a piece of software can tell that the ACA500plus is connected if it's been launched in cloaking mode.

    Please send a screen shot of the exact setting that you're choosing - I'd like to find the cause, as this may be the first program that can detect presence of the ACA500plus since it's been on the market.

  • hi, You Can find in attach differents config that i used to try Platoon each files "a" are config file and "b" files are problems with that config...

    I tried different config the error screen arrives either directly when playing or after a few minutes of play. Only config n ° 7 never crashes the game but only @ 28 MHz.

    3 Zip files Part1, Part2, Part3

    Best regards,


  • In this attach 3 info screens about my SYSTEM

    Information about my ACA500 PLUS ROM v0.135 Dismo V1.7 dec-20-2016

    A500 Rev.6A PAL ECS (512K+ 512k in Trapdoor with RTC directly on Trapdoor)

    Best regards,